Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Crazy Nonsense with Bluetooth connection

(Topic created on: 05-04-2022 11:40 AM)
Members_FR55dTU
Apprentice
Options

Hi all

Can anyone help with the following Bluetooth Problem.

My phone is paired to a number of Bluetooth devices and they all work fine. Except for the inbuilt bluetooth in my Skoda. The phone connects to the Bluetooth of the car just fine, and I can play music via A2DP. With a bit of fiddling I can also make calls as you will see.

But what is happening is that when in the car and I receive or make a call, on the car kit, the phone tries to trigger the voice element on my smart watch and not the car kit.

Lets look at the setup of the two main devices

 

S21+ CrazyBTSystem01.jpg

 

As you can see from the image above, the Skoda carkit is enabled for calls, and the Huawei Watch GT2 Pro is not enabled for calls.

In the next image we can see what happens when I try to call by voicemail from the car kit.

S21+ CrazyBTSystem02.jpg

The image of the phone shows the connected call is trying to connect to the smart watch - (small yellow box on the left). since the watch is not enabled for calls, the call is only taking place on the handset itself.

Now if I click the watch in the small yellow box, I get a pop up asking me to choose from 2 devices.

If I select the Skoda BT 3904 then as can be seen from the rightmost image the Skoda kit is selected and it is "green" active - so the call is now taking place on the car kit.

Interesting to note that if I select Huawei Watch GT 2Pro in the middle image, the call does take place on my SmartWatch.

 

First and foremost, I never had this behaviour with my previous device, a OnePlus 6T, that was bulletproof with it's Bluetooth implementation.

 

Clearly the SG 21+ is not working as it should be - is there a way to specify the default bluetooth device for calls because the current situation is basically unworkable for me and I might as well send the new handset back to the carrier.

Thanks in advance for any advice.

 

10 REPLIES 10
Cosmin-J
Explorer
Options
Hey, I got my s21 ultra 5G , and I'm sure is something regarding your setup, basically my calls always goes on the phone, automatically on the earbuds if I got them in my ear or automatically if I'm in my car , I need to manually send to the watch or answer on the watch to speak on it , please double check if there's a default option to set which the call to be sent to , mightbe your watch settings, by default should be the car as your driving (try using android auto) I'll take my earbuds in the car and have a small test which is using first the car or earbuds, but definitely not the watch, should use by default the phone.
Members_FR55dTU
Apprentice
Options

It's definitely weird because I'm sat at my desk and right now my phone is connected to my watch and  Plantronics Bluetooth headset. In this configuration I get exactly the same behaviour. So if we think about the 4 devices:

1 Car, 2 Watch, 3 Headset and 4 Mobile Device

The only thing to change is the 4th item Mobile Device. I never had this issue with my OnePlus 6T at all

Interestingly, if I go into the phone's Bluetooth settings and disconnect from the watch, I still get the same behaviour. only when I power off the watch does the Bluetooth connection take place on the car/headset as required.

I wonder if it is connection order, so I'm thinking of unpairing the watch and setting it up again

 

0 Likes
Members_FR55dTU
Apprentice
Options

OK, well I didn't expect it to work, but it has - I went into Bluetooth settings, and unpaired the watch.

Then I made a call to ensure that it was placed on the headset - it should work as it is the only connected device at this point - and it did indeed work as expected.

So then I went into Bluetooth settings again and re-paired the watch as well as linked it to my account in the Huawei health app.

First test placing  call and it came up on the headset

Just been out to the car and Second test placing a call and it came up on the car kit

Technology is weird sometimes - it has to be something to do with the way Samsung bugger about with Android though. 

 

Key thing to note - don't mess about with the Bluetooth settings for the watch after getting it to work - or the whole situation starts again.

tavi_19791
First Poster
Options

Have same problem. have you find another solution, pls? After some time after disconect and reconect the problem reapear....

Piszi
First Poster
Options

I have/had the same issue.

When my watch magic 2 (its the same as the GT2 but with Honor branding) is connected to the phone it has always the highes priority in the bluetooth stack and because of this I couldn't use my car audio for calls or actually with android auto it was worse, you couldn't even select bluetoot the phone always defaulted back to phone internal speaker.

Now after a test with my earbuds it looks like downgrading Huawei Healt app did the trick.

This is how I did it:

I did not disconnect my watch from the phone.

Went into Settings -> Apps and force stopped Huawei Health, than I deleted app cache and data, after that uninstalled it.

Than I installed Huawei Health from Google Play (because it has an older version [v10.1.1.312] than the latest update[v12.1.2.330])

After install I re paired my watch in the app than rebooted the phone.

Now as I said earlier it looks like everything is back to normal.

Also if you have HMS Core app installed uninstall that too. HMS Core is not required any more for Health app to work properly.

Oh and the most important! Do Not Update The Huawei Healt App!

khedr30000
First Poster
Options

2 days searching for this for my new A52S 
Galaxy A52s - Galaxy buds pro (as your car kit) -  Huawei Watch GT2
i did like you said ... remove the watch then pair it again 

BIG FAT THANKS

0 Likes
tavi_19791
First Poster
Options

Big thx....

0 Likes
Members_tVEmvxY
First Poster
Options

I have the same problem,  same phone and watch, but an xc40. 

0 Likes
ceshea
First Poster
Options

Thank you,  you solved my big problem.  

0 Likes