Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Unable to connect Samsung Gallery to Onedrive

(Topic created on: 25-03-2020 05:59 PM)
Anonymous User
Not applicable
Options
Galaxy S20 Series

I am new to the S20, having only received it yesterday.

I am triyng to connect Cloud Sync, from within the Samsung Gallery application to Microsoft Onedrive.

 

Each time I try and connect, after I have entered my details in the 'Samsung Account/Microsoft sync webpage', I get the attached error: Server error occured...

 

 

Can anyone assist at all?Sammy.jpg

 

31 REPLIES 31
bazzz
Pathfinder
Options
Galaxy S20 Series

Have you have two step verification turned on for your MS Account? If so try connect without the two step. See if

that helps. Other than that have you had a search around for other forums discussing it, like this one on MS.

vietvu
First Poster
Options
Galaxy S20 Series

Yay ! I have exactly same issue on Note 10+ 

0 Likes
vietvu
First Poster
Options
Galaxy S20 Series
Confirmed. Turn off 2 steps and connect will be worked !
brendonuk
Journeyman
Options
Galaxy S20 Series

This is ridiculous I've gone from IPhone to Samsung flagship phone and cant get this working without turning off 2fa on ms account which is a big no no. Also tried turning it off then back on after and it breaks the connection. And now I've just found typing this freezes the screen until I minimise the keyboard on the phone 👎🏼👎🏼👎🏼

agb
Apprentice
Options
Galaxy S20 Series

OMG! This is amazingly bad! You are exactly correct: you turn off 2FA, sync, then when it's complete you turn 2FA back on your Microsoft account and it breaks the Samsung connection.

 

Come on Samsung, get into the 20th century

PM13
Voyager
Options
Galaxy S20 Series

Thus is more than ridiculous. Of course I will not turn off 2FA on any account. Samsung should be sued for this, as it is unlawful by certain acts (e.g. GDPR).

 

@Anonymous User @Samsung, as long as you do not change this, of course I will not let you use OneDrive

Anonymous User
Not applicable
Options
Galaxy S20 Series

+1 on this problem. I can't believe this is a 2FA problem. I contacted Samsung support via the Members App about this and they keep "putting me on hold" then never coming back. 

 

Please get this resolved @samsung!

Anonymous User
Not applicable
Options
Galaxy S20 Series

I've found a work around for this problem without turing 2fa off. 

 

My previous setup, Microsoft Account + Authy for 2FA codes. 

 

All I did was download and configure Microsoft Authenticator App. Instead of choosing to sign in with Password and 2FA code I just selected the Microsoft Authenticator app as the auth method during setup. 

 

This worked for me first time so this 2FA use case must have been tested but not the other one. 

 

Hope this helps others. 

Ollje
First Poster
Options
Galaxy S20 Series

Thank you so much!

I can infact confirm that using Microsoft Authenicator works, and you don't have to disable 2FA to connect Samsung Gallery with Onedrive.

0 Likes