What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

Samsung S20 FE multiple issues

(Topic created on: 12-05-2021 10:21 AM)

I own Samsung Galaxy S20 FE from less than a month but already experiencing multiple issues like :
1. Ghost/phantom touch
exampe : display registers an input without my intervention
2. Touchscreen - responsiveness/or non-responsiveness
 for example:
1)While I`m typing the bottom left part of the dysplay(left part of the keyboard) requires multiple taps of the screen (arround 10 taps in the letter "d" area) before it reacts/recognise tap , at the same time the bottom right part of the display(right side of the keyboard) reacts accurate to every single gentle tap. Tapping 10 times the "Close all" button before the action take place is another example.
2) When I open image from the gallery and pinch-to-zoom, that closes the image on every second or third time.
3) Today I barely answered a phone call because it recognised the swipe of the green handset at the 3rd or 4th time.
I have to mention that I peeled off the factory screen protector more that week ago thinking that will solve the problem, but it makes no difference.
4)Few times already appeared black spots arround the fingerprint while I was unlocking the phone (like half cyrcles on the top left side and left side of the finger print scanner)
3. Delay/ latency
1) I sometimes experiance lag in simple tasks like rotating a image. It is clearly visible and annoyng when rotating broshure from application,becouse half screen became black.
2) My ringtone tears at the begining of incoming call (like it struggle to start)
Often the phone feels like you gave dificult task to very poor computer,it struggles. And I'm curious if it's a software or hardware problem, if someone else is having so many problems, or just me with my factory-defective phone.


Jaime 1264
First Poster

Same problems here. Also for no reason the phone keeps on re starting rebooting by it self. Annoying. I am taking this garbage back. Samsung whats wrong with this company 

First Poster

I have the same problems and its pretty annoying... 

Pieter the DJ
First Poster

Had all the S Series since s5 and none of the phones gave me any issues ever...until i got the S10. It had issues since i got it till i sold it last year even though Samsung replaced the COMPLETE MOTHERBOARD TWICE.? 


Now i have s20fe. Same story. 

The very first day i got it (11 Nov 2020) it wouldn't fast charge and touchscreen had issues. Took it back to Vodacom to show them. They wanted to replace the phone but i have the cloud red model and i would have to wait almost 2 months to get a cloud red one because they had to wait for stock to come during covid. 


A month later my phone stopped charging completely. On any charger i tried. After 4th factory reset it started charging again. 

When i record 4k video it overheats. 

A few days ago on mother's day ibopened camera app and it randomly just started taking pics all by itself. We were watching the phone lie on the table of the restaurant taking pics by itself. 

That evening i factory reset it again and it became so hot i couldn't hold t in my hand. When it booted up an error popped up... something of C failure. 

Factory reset it again,got extremely hot yet again and error showed again. 

I kept on factory resetting it till it would not get hot or give the error. 


Last night when i tried to unlock the phone it crashed and rebooted. When i opened Samsung members app today this was on the screen

Screenshot_20210512-102110_Samsung Members.jpg


Hey @Pieter the DJ 

This is definitely quite strange. Since you've performed a Factory Reset, and the issue still persists, have you tried submitting an Error Report on the Members app, so our engineers are able to get a better understanding of the issue? If not, please head into the Samsung Members app > Get help > Error reports.


When Samsung will fix the double input bug after a reboot on the S20FE? The A72/A52 didnt have this problem.

After a reboot the S20FE 5G (got 2 devices) insert every time 2 Inputs instead of one while enter the sim pin. 

When i press one time one a number it appears two times. ** instead of *. 


Please fix