Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

No video calls on S20?

(Topic created on: 22/03/21 00:45)
skepasti_21
First Poster
Options
Galaxy S20 Series

Hello, it seems that native video calling gone missing from dial menu on my G781B. I mean that by tapping the video calling icon in a contact, a message pops up  which says "make video call with". I have Google Duo ready set with my Gmail account. I know that by tapping on that icon, it should transfer me to Duo but it won't. One other strange thing there is no "make video calls using" option on phone calls settings. But I can make video calls through Google Duo app. Can someone explain what is happening?

0 Likes
Reply
11 REPLIES 11
Kris G
Navigator
Options
Galaxy S20 Series

google how to 'set up duo with your phone number'.
Or just open the 'Duo' app and in top right cornet open settings, on top the first thing 'Account' , there your google account email and mobile number should be visible, if it's not, then add it.
Also, make sure Duo has all permissions (you probably not allowed it to make calls?).

If you are set up in Duo, your friends will see your number under 'connect to' and not under 'invite' , bcoz you can't invite someone who already activated Duo.

Funny, that i didn't have to activate or do anything on my Xiaomi phone, and it was already working.
But on my S20 Ultra(G988B) i actually had to type in my phone number and activate it.

Huawei P8, Mate10Pro, P40Pro;
Samsung S20Ultra;
Xiaomi MiNote10;
0 Likes
Reply
skepasti_21
First Poster
Options
Galaxy S20 Series

No you seem that my question wasn't clear enough. Native video call missing. When ever i tap the camera icon in any contact, nothing happens and message pops up saying ''make call with''

0 Likes
Reply
Kris G
Navigator
Options
Galaxy S20 Series

ahh this " When ever i tap the camera icon in any contact, nothing happens and message pops up saying ''make call with'' is what you have supposed to post as a question 😉
hmm, well, i actually use the google contacts app, bcoz the one from samsung is too fancy, i like it simple, but i just checked and both apps work fine with video calling, it immediately switches to Duo.
But from what i see you got S20 FE and i have S20 Ultra, if that makes any difference.
How about you uninstall Duo, if you can, and install google contacts app, then install Duo, set google contacts as default app, and set up Duo; - it's worth a try.
if that won't work then there is a different problem than just settings, in that case i would send feedback with the screen of the message you get.

Huawei P8, Mate10Pro, P40Pro;
Samsung S20Ultra;
Xiaomi MiNote10;
0 Likes
Reply
skepasti21
Explorer
Options
Galaxy S20 Series

That didn't work either, thank you though

0 Likes
Reply
AndrewL
Moderator
Moderator
Options
Galaxy S20 Series

@skepasti_21: Can you try heading to Settings > Apps > Tap the 3 dots in the top right > Permission Manager > Telephone > Duo, and make sure that 'Allow' is selected here. If it is, go back to Settings > Apps > 3 Dots > Reset App Preferences, then open the Phone app, select a contact and tap the Duo button. Does this now prompt you to open the video call with Duo?


0 Likes
Reply
skepasti21
Explorer
Options
Galaxy S20 Series

Thank you for your time but unfortunately it gives me the same message, "make call with"

0 Likes
Reply
Kris G
Navigator
Options
Galaxy S20 Series

one last thing, if you have one google account, but multiple phones/numbers, you can use only one for video calling with Duo

Huawei P8, Mate10Pro, P40Pro;
Samsung S20Ultra;
Xiaomi MiNote10;
0 Likes
Reply
skepasti21
Explorer
Options
Galaxy S20 Series

That gave me a hint and the fact that my device is a dual SIM device I came up with the idea to deactivate the one SIM slot, well I did, and it did work with one SIM ,then I crossed my fingers to work with both sims enabled and IT DID!!!! 😁😁😁

Thank you guys for your time!!!

Update!

@Kris G  @AndrewL  unfortunately it works only if i set as default only one SIM for calls, if i choose the option "ask before call" that causes the issue with video calls. Its a bloody bug and SAMSUNG should be aware of this!

0 Likes
Reply
Kris G
Navigator
Options
Galaxy S20 Series

one more bug to the long list of other bugs 😅

Huawei P8, Mate10Pro, P40Pro;
Samsung S20Ultra;
Xiaomi MiNote10;
0 Likes
Reply