Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

My Wi-Fi keeps turning off all of a sudden...

(Topic created on: 03-08-2022 05:31 PM)
34944 Views
lpkeates
Apprentice
Options
I don't have any apps that can turn off the Wi-Fi itself, but even if my Wi-Fi router (at home) is fine, it just to turns the Wi-Fi off automatically on my phone. This has happened a few days ago, and my phone is up to date. Regardless, nothing is in "Wi-Fi control history", and I don't have the "Wi-Fi power saving mode" option. I don't know what could be done in the developer options, but if you have a clue, please let me know.
0 Likes
9 REPLIES 9
Dandy__
Pathfinder
Options
Hi IPkeates happen even to my S22 but it's not your phone it's a connection issue between phone an WiFi do sometimes even your phone is resetting your WiFi to clear some cache or sometimes it's a bad connection between phone and WiFi
Mirulmaar
Student
Options

Same with my S20FE.

I turned off "Switch To Mobile Data" option. Maybe this will help.

Mirulmaar
Student
Options

Nope 😞 it didn't work

0 Likes
AndrewL
Moderator
Moderator
Options

@lpkeates: To begin with, please try resetting your router by unplugging it at the wall for 30 seconds, then plugging it in and powering it back on, then restart your Galaxy S20 to address any temporary software issues that might be a contributing factor. Following the reset, head to Settings > Connections > Wi-Fi > Tap the 3 dots in the top right > Advanced, and switch off 'Turn on Wi-Fi automatically'.

If the issue occurs while you're using a certain app then please try heading to Settings > Connections > Data usage > Mobile data only apps, and check to see if any apps are listed here that might be disabling your Wi-Fi when in use. Also, head to Settings > Advanced features > Bixby routines, to see if any routines are set up that might disable your Wi-Fi under certain conditions, or that turn on features that disable Wi-Fi, such as Flight Mode. 

0 Likes
Patricia C
First Poster
Options

I have a Samsung 23 and wifi kept turning off for no reason. I went into my Mobile Networks/Network Mode and it was set to 5g network. My carrier doesn't have the 5g network so I changed it to the 4g network. So far my wifi has not dropped since doing this. Im no techi so I'm not sure why this would have made a difference but it has so far! 🤞

0 Likes
Shaggyeren
First Poster
Options

My s20 does not show Turn on Wi-Fi automatically under the advanced settings

Screenshot_20231005_010147_Settings.jpg

  •  The wifi turns off and the screen goes bright constantly regardless of what wifi network I connect to. It isn't my wifi connection. My s22 has no issues. I did find an app called modes and routines that I have never downloaded under wifi history (not the Turn on Wi-Fi automatically. Not Mobile data only apps. Not Bixby pure trash routines)  Screenshot_20231005_011754_Customisation Service.jpg

     I have done my best to deactivate this flaming trash that I cannot uninstall. I am currently in hospital with only the s20. If this garbage also affects my other Samsung devices then I'm permanently done with Samsung. That Bixby garbage should have been teason enough why I should never have bought another Samsung. I was stupid and stayed with Samsung.

0 Likes
AndrewL
Moderator
Moderator
Options

@Shaggyeren: I'm sorry to hear of your frustration surrounding this matter. If you are currently in hospital, and not in a familiar or frequently visited location, then please try heading to Settings > Connections > Wi-Fi > Tap the 3 dots in the top right > Intelligent Wi-Fi > Turn Wi-Fi on/off automatically, and toggle this option off. Tap the back button, then tap the cog to the right of your current Wi-Fi connect > Auto-Reconnect, and make sure that this is toggled on. Now, when you enable Wi-Fi, it should default to your preferred Wi-Fi connection, and hopefully address any stability issues you're having. I also recommend restarting your Galaxy S20 to resolve any temporary software issues that might be affecting the performance of the device. 

0 Likes
kasmani
First Poster
Options
When I turn on wifi on my galaxy a51 then after 10 seconds turn off automatically
Stub_Mandrel
First Poster
Options

My Galaxy A51 has daily issues.

Often it has a full wifi signal but says 'not internet connection' and I have to disconnect snd reconnect. Even when I have a full signal.

 

Worse, sometimes if I switch wifi off and then on again, it connects, works for a few seconds, then switches itself off. This then happens every time I try to switch wifi back on and the only solution is to restart the phone.

It is obviously the phone not the router as redtarting router doesn't stop it but restarting the phone does.

0 Likes