Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Hiya Caller ID and Spam protection doesn't work

(Topic created on: 15-07-2021 02:52 PM)
sophe
First Poster
Options
Galaxy S20 Series

I have an S20fe. On my old S8 the spam call screener worked perfectly; on this s20 it doesn't. 

I have obviously turned on the option to "block all calls" but I still get them. 

Any reason why? And anything I can do about it?

I live in Italy. Thanks in advance

 

0 Likes

1 Solution


Accepted Solutions
Solution
AndrewL
Moderator
Moderator
Options
Galaxy S20 Series

@sophe: Where did you purchase your Galaxy S20 FE from? It may be the case that it is intended for use outside Italy, which can lead to compatibility issues with some apps and features. Just to double check, please head to the Phone app > Tap the 3 dots in the top right > Settings > Caller ID and Spam Protection > On > Block Spam and Scam Calls > On. 

View solution in context

0 Likes
2 REPLIES 2
Solution
AndrewL
Moderator
Moderator
Options
Galaxy S20 Series

@sophe: Where did you purchase your Galaxy S20 FE from? It may be the case that it is intended for use outside Italy, which can lead to compatibility issues with some apps and features. Just to double check, please head to the Phone app > Tap the 3 dots in the top right > Settings > Caller ID and Spam Protection > On > Block Spam and Scam Calls > On. 

View solution in context

0 Likes
sophe
First Poster
Options
Galaxy S20 Series

Yes, thanks - I found out that my phone was made in Malaysia, so I'm now sending it back and buying the version "italiana". You learn something every day..!