Support

Open search

OneDrive No Longer Synching from SD Card to OneDrive Camera Roll Folder On S20 Ultra

Highlighted
SOLVED
Apprentice

I have an S20 Ultra and I can no longer synch my photos from my SD card to the OneDrive Camera Roll folder. It will only sync from internal storage to a new folder called Camera and this becomes a hassle because of limited space on the internal storage and requires constant moving around of pictures and videos. I'm wondering if anyone here knows of a work around to some how get the SD card to sync again with OneDrive photos. I bought this phone mainly because of the camera and this is very dissappointing. 

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Apprentice

Not sure if I can post the link but here is what I was able to do to disconnect the Samsung Gallery app from OneDrive and get my SD card to start synching again with OneDrive. 

 

1. Go to the Samsung "gallery app" and tap the three dots in the mid right of the screen and select settings and then turn off "cloud sync". 

2. Next you have to disconnect the Samsung Gallery App from OneDrive 

 

3. To disconnect your Samsung Gallery from OneDrive follow the instructions below:

If you want to stop the Samsung Gallery app syncing photos to OneDrive and remove the Samsung data sharing permissions to your Microsoft Account, you'll need to edit how you sign-in to Microsoft:

  1. Open your Microsoft Account's additional security options.

  2. Next go to Samsung Account and select remove.            

After you complete the above go to the "phone settings", "accounts and backup", "accounts" then look for your OneDrive account. Open your OneDrive account and make sure "sync account" is on for all items. I did this a while back and it's working flawlessly so far. The only thing that will not sync directly is the 4K video I believe which can only be saved to the internal phone memory. I haven't yet tried moving a 4K video manually from the internal storage to SD card to see if it will sync with OneDrive.  I hope this helps anyone having similar issues and please let me know if any of the steps I mentioned above were incorrect in any way.    

 

 

View solution in original post

Highlighted
Apprentice

In the OneDrive app, select Camera Upload:

 

Screenshot_20200901-173908_OneDrive_LI.jpg

then select Additional folders:

Screenshot_20200901-173926_OneDrive.jpg

I turned off "Notify me when a new media folder is found".  It seems that by default the app discovers those folders but doesn't enable them.  There may be another setting that controls that, but you can see that those folders are turned off on my phone.

View solution in original post

32 REPLIES 32
Highlighted
First Poster
I would also like to know the reason/answer. Mine has stopped since switch from Samsung Cloud to Onedrive.
Highlighted
New Member

I have the same problem on S9+. I have the same concerns as you have and that is why I also pay a premium storage on Onedrive

Highlighted
Apprentice

Not sure if I can post the link but here is what I was able to do to disconnect the Samsung Gallery app from OneDrive and get my SD card to start synching again with OneDrive. 

 

1. Go to the Samsung "gallery app" and tap the three dots in the mid right of the screen and select settings and then turn off "cloud sync". 

2. Next you have to disconnect the Samsung Gallery App from OneDrive 

 

3. To disconnect your Samsung Gallery from OneDrive follow the instructions below:

If you want to stop the Samsung Gallery app syncing photos to OneDrive and remove the Samsung data sharing permissions to your Microsoft Account, you'll need to edit how you sign-in to Microsoft:

  1. Open your Microsoft Account's additional security options.

  2. Next go to Samsung Account and select remove.            

After you complete the above go to the "phone settings", "accounts and backup", "accounts" then look for your OneDrive account. Open your OneDrive account and make sure "sync account" is on for all items. I did this a while back and it's working flawlessly so far. The only thing that will not sync directly is the 4K video I believe which can only be saved to the internal phone memory. I haven't yet tried moving a 4K video manually from the internal storage to SD card to see if it will sync with OneDrive.  I hope this helps anyone having similar issues and please let me know if any of the steps I mentioned above were incorrect in any way.    

 

 

View solution in original post

Highlighted

Hi,

 

Yes it worked. Thankyou so much.

 

I was very disappointed thinking there would be no fix for this. I mean, as the same case where Samsung just stopped saving 4k videos to the SD card.

 

Thank you!

Highlighted

Hello,

 

I  wanted to let you that this solution works great. 

I bought a S20 and since then the camera upload function disappeared in the onedrive app.

Now its back and photos from the sd card are synchronised to onedrive again. 

 

Thanks. 

Highlighted

Signed up especially to say thank you. So irritating that something that purported to make things better actually made them worse!

Highlighted
Thank you so much!

Samsung likes to force things upon us it seems. If we choose to use Onedrive don't force us to use Samsung Cloud....
Highlighted

Thank you so much! 

Shame it does not work out of the box like this.

Highlighted

This worked, thanks for sharing!  Note: Since I access my Gmail account in Outlook on my Samsung phone (got that?!), I decided to skip Step 3, and leave my Samsung account connected to Microsoft.  The only side effect is that I now no longer see my previous OneDrive (CameraRoll) photos in the Samsung Gallery.  Ah well, guess they moved my cheese again! 😉

Top Liked Authors