Support

Open search

Overheating fix for s20

Highlighted
Apprentice

PLEASE READ AND TRY THIS FIX!!!!!!! I have a s20 4G and i was facing overheating problems and to cut it short, the fix consists in DISABLING VIVID COLOURS and USE NEUTRAL COLOURS in the settings. Before doing this, my cpu temperature was staying around 38C and 42C with normal use (scrolling through insta, chrome and youtube) but then it would go up to 44/45C after a minute of asphalt 9. Phone was extremely uncomfortable to use. I disabled vivid colours a few hours ago and the temperature was staying around 31C and 34C. Then I opened real racing 3 and after one race the highest temp the cpu got was 36C.  I haven't seen anything higher than 36C yet and I already got used to the colours. I have more testings to do but so far so good and I hope this is the actual problem so that Samsung can work to fix it. Battery still goes down fast but that's just normal with this phone, there's no fix for that. Share the solution if it works for you.

6 REPLIES 6
Highlighted
Apprentice

Update: I'm currently downloading the extra files for real racing 3 and the temperature got to 38C but that is normal since the screen has been on for quite some time using a lot of wifi + it's no where near as hot to the touch as it was before. DISCLAIMER: this fix isn't 100% guaranteed to work but give it a try as it basically lowers the brightness of the colours which would usually heat up faster, just like light bulbs, the brighter, the hotter ( not always but often ). Maybe I can find some third party app to get the colours back to normal but the built in option is simply broken.

Highlighted
First Poster

Hi Matteo,

 

Any update for it? I am planning to replace my phone to S20+, but it seems bad now.

Highlighted
Apprentice

Replace it, the fix unfortunately only lowers it by 1/2C.  Samsung doesn't recognise this as a problem.

Highlighted

I actually found the real fix. Use the 60hz with hd+ for a week, your phone won't overheat. After a week if it works use full hd+ and if it works you can move on to qhd+ but forget 120hz.

Highlighted
First Poster
my phone stopped overheating once I did these three things.
1. factory reset
2. use 60hz
3. hd+ resolution

after a few weeks I was able to boost up resolution and finally refresh rate.
Highlighted
New Member

Changing vivid to natural reduced the overheating for me considerably.

Top Liked Authors