Open search

Delay between pressing camera button and picture being taken resulting in missing the shot


Hi all,


S20 Ultra here, have taken plenty of great shots with my camera, the quick updates since launch have fixed most issues people had at launch with the cameras but somthing that occasionally bugs me is a delay in capturing a photo after pressing the button, resulting in missing the shot.


Typical scenario - taking a photo of my kids , they move a lot so you dont have long to get a shot, I  pull the the phone out, line up the shot and press the button and nothing, 1 second, maybe 2 and it takes the shot and its not the shot you wanted.


It certainly isnt all the time, sometimes the shot is pretty much instant, I am begining to suspect its related to the auto focus, the phone doesnt focus quick enough or maybe doesnt think its focussed (often it looks fine on screen) so wont take the shot quickly when you need it to.


Any ideas?




Check software update in your settings 

Settings > about phone > software information > security patch date 

I don't think that the issue is an ultra only issue. I have the regular s20 and I experience the same issue. So, there's a good chance it's a software issue. I still haven't figured out how to fix the issue though. I've tried a couple of things. Factory reset the cam app, updating the software - on the newest now, clearing cache, turning off any software thingie in the cam app that could affect the shutter speed. But nothing seems to help. I think I might try wiping the phone all together unless someone has a brilliant idea? Also, if I use a third party cam app like the Photoshop camera app shutterspeed is not an issue. It works instantly on all shots. Heck, my s10 seems to do a better job 😒


My S20 Ultra has got this problem recently, should be after the latest update (with Security patch July 1 2020). I did not notice this problem before the update.

I can barely believe it, the latest update appears to have completely resolved this issue.


Taking pictures of my kids this morning every tap of the shutter button on was instantly taking photos.


Better late than never I suppose.

Yep noone believed it, but July fixed them and another July update in the pipeline, already in some regions, meant to have camera improvement ls too

Helping Hand

Try disabling all AI, Scene optimiser, suggest best shot, and tracking autofocus, they add delay and tbh don't do much but improve saturation which you can all later in edit


PS is the latest photo editor crashing for you? I've had to roll back

I have just tried. It takes 10 minutes for the photo to show up in the galary...

Make sure you have the latest system updates and Is your cameras save location set to internal or sd card? If you have it currently set to a sd card try switching it to internal storage to see if that helps.


Camera app>setting>storage location

I did not see any problem until the latest update. No SD card is inserted into the phone. The photo shows up after minutes is by luck. Sometimes it never show up... I plan to reset my phone now.

Top Liked Authors