Open search

Wifi problem on s10+


Is any one having issues with wifi on s10+ my broadband is 200mbps in speed when connected to wifi it takes long to load like Google page and Facebook or messenger.

Then I turn off wifi its perfect on 4g.

My all other device are fine on wifi.

Any one else having this problem.


128 REPLIES 128

Check your router settings and disable the use of 5 GHz DFS frequencies. I found that setting for my Fios router in the advanced settings through the My Fios mobile app. Once I disabled DFS, my S10e speedtest went from around 40 Mbps to 200 Mbps from my room 1 floor above my router. (I have 1 Gbps service from Fios, btw.) Prior to disabling DFS, I would consistently get lost WiFi signals.


Good luck!

Here is another issue.  My wife and I have the same S10+ phone, with the same settings, and same case.  We are connected to our 5Ghz FIOS service and her phone is connecting at a blazing 850 Mps and mine right next to her phone is at 185Ghz.  I restarted both phones and triple checked the settings and her phone is still in the 800's and mine is sub 200?  Both phones are on a desk and I swapped them and the results are the same?? 

Check to see if both phones are connected to the 5 GHz network. Your wife's phone may be connected to the 5 GHz network, while yours is using the 2.4 GHz network which isn't able to provide the high data speeds that the 5 Ghz band does. If you're using the Self-Organizing Network (SON) feature on your router, that may be assigning your phone to the 2.4 GHz network. Once you disable SON through the My Fios mobile app, find the name of the 5 GHz network and connect your phone to it, then re-run the speedtest.

Thanks CPSMA for the input but everything is the same and we are not using the SON. I have the networks split and setup as seperate networks to sign into. 

Where did u find these settings? I can't see them anywhere... 

I have the US Unlocked S10 Plus and can confirm that having Bluetooth on slows down WiFi Speed. Why is that??? It's unacceptable

First Poster

I am in Canada and have a s10+ that I purchased when it was released.

I confirm the same behaviour as VSHOCK above.

Disabling Bluetooth instantly resolves my speed issues.

My wife has a s10e, no problems whatsoever.



New Member

I fixed my issues! Reset network settings in Settings, General Management. Reboot phone in Safe Mode by holding down volume button while booting. Reboot phone into normal mode. Worked for me!

New Member

I have the same issue. I disconnect from my Wi-Fi  and reconnect and it's fine. My other devices have no issues.  Iphone, tablets and computers are all fine. I think it's a software or hardware issue with the Samsung mobile phone. I guess I will be changing from Samsung to something else.

Top Liked Authors