Support

Open search

Wifi problem on s10+

Highlighted
Apprentice

Is any one having issues with wifi on s10+ my broadband is 200mbps in speed when connected to wifi it takes long to load like Google page and Facebook or messenger.

Then I turn off wifi its perfect on 4g.

My all other device are fine on wifi.

Any one else having this problem.

Thanks 

127 REPLIES 127
Highlighted

note wifi speednote wifi speedlaptop wifi test.laptop wifi test.

Highlighted
Observer

I am having a similar issue. I am sitting 5 ft from router in open space.

Setup:

150Mb/s Comcast account

Netgear Nighthawk triband router 

T-Mobile repeater range extender plugged directly into said router (basically uses wired internet as a backbone and transmits 2g to 4g LTE between only my phone's with my plans sims). 

I am getting 50-70 % of the time 1.8 then a slow drive up to ~10Mb/s speeds.  I turn wifi off and I get ~80-100Mb/s with LTE through the same router.  I do realize my router could be the issue but no other device (iPhone 10Xs Max) has the issue.  Idk what to do. We have a wide range of other flagship devices in-house as well that do not have the issue.

Highlighted

Similiar problems here on 4 day old Samsung S10 (UK): wifi very flakey, keeps dropping with "authentication error occurred"

 

Things I've tried:

  • Disabling all the Wifi bloatware settings - no difference
  • Connecting to guest wifi on same router - no difference
  • Disabling bluetooth - no difference
  • Resetting all settings - as per advice by Samsung support - no difference

argggghhh

Highlighted
Nothing of factory resetting or wifi settings helped for me as well. Eventually what helped was the disabling of the two bands 25 and 42 or something like that. Those instructions are listed somewhere in this thread or forum. I still see some flakiness once in a while very rare but for regular use it is back to normal
Highlighted

I was told the same thing but separating the networks did nothing!  Both of my S10's 144 to 55 Mbs then nothing, have to keep connecting and disconnecting to get better speeds!  My S7 Edges's 600 to 880 Mbs, Galaxy Tab S3 800+ MBs.  Same network, so why does a brand new phone have such issues with Wi-Fi?

Highlighted
The only ones that can fix this issue is Samsung. So far nothing fixes the page loading and slow speed issues and I'm sure it's down to poor hardware rather than a software issue myself.

My advice comes from being a UK Samsung Phone User.
Current Phone ~

Samsung S10+ 128Gb > Model: SM-G975F. Samsung One Ui 2.5 / Android 10.

Samsung Galaxy Watch3 > Model: SM-R840.
Samsung Galaxy Buds+ > Model: SM-R175.
Highlighted
I've given up for now checking on WiFi speed tests.

To be honest I don't feel like my download speed is actually affected. Just the speed tests are not represented correctly. Who knows though.

Iam not having this problem either "authentication error occurred".
Highlighted

Just got off the phone with Samsung.  I was told this is the first they have heard about this issue!  They offered to setup shippment of both of our phones to be checked by them as there are no Samsung tech services centers in our area. 

7 to 10 day turn around time.  

Highlighted

I have done all the resetting and the phone seems to work better but then starts to slow down again and disconnect.  This is and has been happenng on both of our S10's which were preordered and arrived when the S10's were released.  I also noted this occurs on every network the phone is used on! It is not specific to our home network.  We use very little Data and found our Data usage was unusually high because the phones would disconnnect from WiFi and we wouldn't notice this and use streaming or other services which use higher amounts of data.  The only reason we went with the S10's is because our S7's Edge's were tied to Sprint and those phones could not be moved to another carrier because Sprint as a carrier doesn't have ability to carry Calls and Internet at the same time!  The Sprint phones have one tuner not two like the other carriers!  Bestbuy never informed  us of this and we complained of issues for two years and once our contract runs out a Sprint tech admits this and confirms the coverage at our home is extremely weak!  This left us with $1800 in phones we could not use and had to purchase again to move to another more reliable carrier.  Now we have two S10's with subpar WiFi.

Highlighted

@CFH2019 wrote:

Just got off the phone with Samsung.  I was told this is the first they have heard about this issue!  They offered to setup shippment of both of our phones to be checked by them as there are no Samsung tech services centers in our area. 

7 to 10 day turn around time.  


That's their standard line: First they have heard of this issue..... It's nonsense.

 

There are complaints all over this board as well as all over the U.S. board of Wifi and LTE issues. Samsung knows full well they put out a subpar product.

 

I can't figure out yet if it is a software issue and they just don't care so no fix is rolling out or they did a bait and switch on their device of using subpar hardware and advertising we were getting one thing when they knew they weren't giving us such hardware in the first place.

Top Liked Authors