Support

Open search

Wifi problem on s10+

Highlighted
Apprentice

Is any one having issues with wifi on s10+ my broadband is 200mbps in speed when connected to wifi it takes long to load like Google page and Facebook or messenger.

Then I turn off wifi its perfect on 4g.

My all other device are fine on wifi.

Any one else having this problem.

Thanks 

125 REPLIES 125
Highlighted
First Poster

Nothing works, I tried all their troubleshooting suggestions. definitely a software issue because I got my original s10+ replaced @jb hi fi and still having the very same issues with the new one. Not happy. 

Highlighted
Apprentice

Are you on virgin media? Hub 3?

 

If so, its something to do with the phone and that hub probably, not sure if I have problems at other locations with other wifi. 

 

They have just agreed to replace mine too, i have to send  mine back to them first, wait up to a week for a replacement. 

 

Without a phone for a whole week only to likely end up with the same problem. 

 

Service level is rubbish if you buy direct from Samsung. 

 

Not doing this again, if the replacement has the same problem I will be asking for a refund. 

 

Terrible way to deal with customers of you new flagship phone that dont seem to work. 

Highlighted
First Poster

Different router entirely. I'll be seeking a full refund if this isn't fixed quickly. 

Highlighted
Apprentice

My WiFi was dropping on my S10+ a few times per hour so I turned off "switch to mobile data" under adaptive WiFi and I've not had any issue in 24 hours.

 

Just search for "switch to mobile data" in settings and it takes you right to it.

 

Good luck.

Highlighted
First Poster

The only thing that works for me is turning bluetooth off, but that is an issue because I use a bluetooth earpiece for work.

 

Does this work for anyone else?

Highlighted
First Poster

Same problem here, wifi dropping out constantly, telling me no internet or just simply drops out and reconnects. Its driving me nuts.

Nothing to do with bluetooth and several other devices work perfectly on the router.

Highlighted
Troubleshooter

Is there anything on your WiFi trying to use the same IP address? I have assigned static IP address in router for phone, always connects when I enter house.


@Lukep2 wrote:

Same problem here, wifi dropping out constantly, telling me no internet or just simply drops out and reconnects. Its driving me nuts.

Nothing to do with bluetooth and several other devices work perfectly on the router.


 

Highlighted
First Poster

Thanks Colin.

 

How would i find out if its clashing with another ip?  is it a fairly simple process to add a static ip address?

 

Would make sense as i've been able to connect to public wifi without any dropping.

Highlighted
Troubleshooter

You go into your router settings, look for WiFi see what address have been given to all network devices. You should have the option to always assign this IP address.

What router do you have?

Highlighted
Troubleshooter


@Lukep2 wrote:

Thanks Colin.

 

How would i find out if its clashing with another ip?  is it a fairly simple process to add a static ip address?

 

Would make sense as i've been able to connect to public wifi without any dropping.


@Lukep2 wrote:

Thanks Colin.

 

How would i find out if its clashing with another ip?  is it a fairly simple process to add a static ip address?

 

Would make sense as i've been able to connect to public wifi without any dropping.


So if you can connect to public WiFi with no issues, then it’s something in your home router that is causing the issue

Top Liked Authors