Support

Open search

USB OTG / external audio interface

Highlighted
Apprentice

Hi,

 

After a couple of futile emails and calls with Samsung techs, I thought I'd post here.

 

I recently upgraded from a S7 Edge to a S10. Everything is fine, apart from I can no longer use an external audio interface as the USB OTG host mode 'cannot switch'.

 

This is a small USB powered interface which is used for mobile recording. The device is recognised and powers up fine, but the USB options will not allow the S10 to become the host device (it tries, but fails and says 'can't switch'.

 

Short of having to root the device, I've tried everything possible. All cables and OTG adapters are fine, even high quality 3rd party ones.

 

I'm thinking this is either an issue with:

1. Android Pie

2. USB type C

3. Power draw (unlikely)

 

Any ideas are welcome at this point! 🙂

36 REPLIES 36
Highlighted
Explorer

Maybe my problem is relevant.

https://eu.community.samsung.com/t5/Galaxy-S10e-S10-S10-S10-5G/Creative-Super-X-Fi-AMP-on-S10s/m-p/1...

My amp wont' work with S10, except when I use USB audio player pro, which uses his own audio drivers and not Samsung's. So it looks like Samsung has done something wrong with S10's audio drivers.

Highlighted

Hi Voodooman,

 

Agree that the audio drivers are likely part of the cause. I also have used USB Audio Player Pro in the past, which is useful for playback.

 

The issue here is using the device for audio input purposes; which simply doesn't work.

 

Beginning to wish I'd gone for the OnePlus 7 Pro at this point!

 

Responses from Samsung Tech are redundant and a waste of time at this point, as they don't understand it themselves.

Highlighted

I upgraded from the galaxy s6 to the galaxy s10 plus. All is great except for every time I plug my external audio interface in my phone it "REBOOT"

 

It still works fine with my S6 but it has never failed to disappoint on the s10 

thought it was a bug that would've gotten sorted out by now but 😤😡🤬

Highlighted

it really does not work? upgraded from s7 being sure there will be no problem with guitar recording!!!

Highlighted
New Member

have the same problem with my S10+ using my schiit modi2 DAC.

¿Any solutions so far?

Highlighted
Apprentice

I'm having the same issue. When trying to plug in any audio interface, the phone recognizes it but behaves weirdly according to which audio source is plugged in. For example:

- Zoom H6n: When plugging in the device and setting on the Audio Interface option on it, the Samsung recognizes it when I start recording something (e.g. from the device Camera) by popping up the message "Recording from external audio source". However, the device will eventually freeze (during or after stopping the recording) and will Reboot. The recorded video will get lost, too.

- Behringer UMC404hd: The device recognizes the device and records. However, when playing back the video, the audio sounds cracked and weirdly tuned (like I switched the audio down a few octaves, sounding like a horror movie).

 

Sadly, I cannot seem to find anything that helps. Found this blog, but it seems Samsung didn't really want to show up here... 

 

Hoping there's a fix available somewhere, someday. At the moment, I'm feeling quite disappointed with this issue on my brand new S10+ acquisition. As a first line smartphone, I never thought it would go through something like that.

Until the moment, I just found a workaround in Google, which consists basically in using an external Mic directly plugged in via P2 cable. < https://youtube.com/watch?time_continue=173&v=ZiD8Z2uhySc&feature=emb_logo >

Highlighted
Apprentice

Got the same issue here with my brand new S10+.

When connecting any external audio sources (e.g. audio interfaces) via the USB port, I have different issues for 
different interfaces.  I'm listing below my testing with three different audio sources:

 

1. Audio Interface Zoom H6n:

- Adjust settings on H6n to work as usb audio interface.
- Open the camera on S10+ device
- Connect USB cable in the phone USB type C port
- A message is displayed: "Recording from external audio source"
- Still in camera mode, tap 'Record' button

 

From there, the device presents different behaviors, such as:

a) S10+ system (Android 10) freezes right when you tap 'Record', and restarts.
*PS: The device also gets considerably hot when bugging!

b) Device starts recording, but when typing "Stop" button it either freezes and reboot or just reboot straight away

 

2. Behringer UMC404HD:

- Plug USB cable into S10+ USB type C port
- Device will power up the audio interface successfully via USB (the audio intrface can be powered via USB or AC adapter)
- S10 will record normally
- When reproducing the recorded video, the audio will sound with a very lower tone (like 3 octaves below the original sound, sounding just like Darth Vader). No lags, no delays, no audio crack, but the tone sounds like Darth Vader.

 

3. P2 port instead of USB port: Works fine. S10+ detects the external audio source via P2 port and records successfully, even when coming from the two audio interfaces listed above. However, I observed background noise from electrical network, if any of the audio sources is plugged into AC.

 

As per contact with Samsung technical support, I tried:

- Device reboot. No success.
- Performed a Hard Reset (Factory Reset). No success.

From there, I raised a ticket to Samsung technical support, considering that - as found in this blog post - there are different users having the same issue, which would exclude the possibility of defect only in a specificy batch of devices (which was considered in the initial contact with Samsung support).

I'll keep you updated on the updates from Samsung support.

Highlighted

Great news is that something has started to work (maybe after last updates).

 

BTW; what is P2 port that worked for You?

Highlighted

Are you powering the interface solely through your phones USB? Some interfaces have an option for DC power.  If not,  you need a powered USB hub for the for some interfaces to work properly. Your phone won't provide sufficient power.

 

Sabrent 4-Port USB 3.0 Hub with Individual LED Lit Power Switches, Included 5V/2.5A Power Adapter (HB-UMP3) https://www.amazon.com/dp/B00TPMEOYM/ref=cm_sw_r_fm_apa_i_dIUHEbR7SB6Z6

Top Liked Authors