Open search

Smart lock not working

New Member

I have set smart lock up several times for trusted location and devices on my s10+. It works for a while then stops. I have followed a few guides such as clearing caches, adding several trusted locations nearby etc but nothing works. My location is on and on high etc.


Please sort this as it worked fine on my S7.

For whatever reason, I went in and deleted my location history and Smart Lock now works for home. I have it set to delete location history that is older than 3 months. It's aggravating, but worth a try.
Hey.. I tried this and it's working for me too for the time being.. I have the Samsung Galaxy S10+.. Can you please tell me if it's still working for you since this post of yours? And if by some chance it stopped working for you, can you please tell me if you found another solution to the issue? Thanks.
My apologies for the double post.. I wanted to edit the post and I accidentally sent it twice.. I'm a new user hence the mishap..

Unfortunately for me Smart Lock has stopped working completely for location! I'm now using facial recognition to unlock or unlocking when it recognises my xunpuls earpods.

First Poster

For me I started having issues after I agreed (when prompted out of nowhere) to add Home to Smart Lock location in addition to manually added Smart Lock location. 

I removed Home, rebooted, waited 15 minutes and it started working as expected. 

I have S10 now. It was finicky with S9 as well so I am hopeful S10 will be better but expecting S10 to be finicky as well.


I used to be a big Samsung fan but not so much the past 1 or 2 years. The Samsung Support Help Desk system is awful and their team of individuals isn't much better. If you write a ticket and they respond (typically with an "I'm sorry but we're not going to do anything about it" response) then the ticket is automatically closed! If you want to respond then you have to start over with a new ticket and talk to another knot-head.

Good luck


Genius. I never thought of this. Now I can set phone to unlock when I am connected to a trusted WiFi network. Not sure why smart lock doesn't have this option. Seems like the best way to do it. 

Top Liked Authors