Support

Open search

S10e compass calibration problems

Highlighted
Explorer

Hello, 

I'm not sure when this started but I've noticed that I have to recalibrate my compass every time I use a navigation app other than Google maps. To be exact, I have to recalibrate the compass every time I get it out of my pocket during a hike. Sometimes it's off by a whopping 90 - 180 degrees! This only happens in apps like Osmand and Locus.

Strangely, Google maps is always working correctly. This is/was confusing to me because I thought there was only one compass. After a lot of reading I figured out that maps needs a different calibration movement than the Samsung compass which is used by other navigation apps.

So, long story short: Even though Google maps compass is calibrated, the compass in other navigation apps is not. Even when I do calibrate it, this calibration doesn't seem to be persisted.

I tried clearing cache of the apps and phone to no avail. Is it possible this problem arose during the last firmware update? What's going on? Any ideas? 

10 REPLIES 10
Highlighted
Apprentice

I can confirm the same issue is on my S10, probably after an update. Worked fine for months. On most apps it cannot be fixed, because there is no compass calibration option.

Google Maps shows the orientation correct. In other other apps the orientation is suddenly rotated by more than 90 degrees.

In the App Locus Map it's possible to enable a "compatibility mode" that helps as a workaround.

In the App Komoot I didn't find any option for an workaround.

99% an issue with an Samsung firmware update, because all compass related apps are affacted at the same time.

Highlighted

Hi Frostbit, 

Thanks for your reply. I tried the compatability mode in Locus, which works a bit better because at least the compass is pointing in the right direction but the compass also becomes very nervous/jittery. Are you experiencing the same thing?

About your conclusion: I think the problems started with the Pie update, so I think it's a firmware problem too. 

Highlighted
Hi Some-dude,
indeed it's jittery. Probably using an older / raw sensor API without any additional filter there.
Did you already contact Samsung support?
Highlighted

To be honoust I haven't contacted support. For some reason I have the feeling it wouldn't make any difference. Usually when I contact support (of any company) I only get the obvious standard solutions which I already tried. That made me become somewhat cynical. 

Maybe I should give it a go though. 

Highlighted
First Poster

Well I have the same on my S10+. It is almost 180 degrees off. Aparently it is not an issue for Samsung for these very expensive phones, because the problem is here for more than 4 months now. 

compas S10+.png

Highlighted

@Ericie Sorry to hear you have problems too... I never found a fix for this problem (except for constantly recalibrating - which is really no solution) and I don't believe Samsung will fix it either. There's only one thing I've never tried : a full factory reset of the phone. The amount of time it will cost to install everything again is just off putting.

Did your phone have this problem out of the box (which os version?) or did arise after an update? 

Highlighted

I am not sure. It did receive several update, so I don't know if it is an issue out of the box. 
I did  contact Samsung support, so waiting now for an answer. 

Highlighted
Cool, let us know what they say when you've received an answer.
Highlighted

I wrote them several months ago about my S10, too. I gave up when they said I should factory reset my tablet. Double fail.

But don't hesitate to contact support. I think it's the only chance to get a fix. Doesn't seem like Samsung is interested in satisfied customers.

 

For now I calibrate in google maps outside each time I am using the compass actively. 

Top Liked Authors