Support

Open search

S10+ no 4g

Highlighted
New Member

Recently got the S10+ but since having it has never connected to 4g. I only have H+ which is really slow. Tried everything recommended online but nothing has worked, any suggestions??

1 REPLY 1
Highlighted
Moderator
Moderator
@HF24: If you go to Settings > Connections > Mobile Networks > Network Mode > LTE/3G/2G (auto connect), this will ensure that the device connects to the strongest available mobile data signal. If this setting is active and the issue persists, I recommend contacting your network to enquire about any restrictions to the service in your area.
Top Liked Authors