Support

Open search

Google Calendar notifications not working properly

Highlighted
First Poster
Hello,

I have a Samsung Galaxy S10+. Last week, Verizon pushed a software update and since then, I no longer properly receive Google Calendar event and reminder notifications. Prior to the update, I'd receive event and reminder notifications via audio ringtone and a pop up window would wake up my screen and display on the lock screen. I also had edge lighting enabled.

Since the update, I don't receive any type of notification for any existing or repeating events or new test events I created. They don't even show up in the drop down notification panel, but are listed in my Google Calendar (phone and web version). For Google Calendar reminders, I get the audio notification, it shows on the lock screen and notification panel, but it doesn't wake up the screen. Edge lighting has been disabled.

I've called Verizon tech support and they told me to clear the cache and data for Google calendar, uninstall/reinstall it, and go into boot mode to delete the cache partition. They also took over my phone and confirmed that the Google calendar notification settings were correct for what I was trying to accomplish. They said the last resort is to do a factory reset which I'd like to avoid or wait for Verizon to push a patch if they feel there's a need for one.

I also tried creating events and reminders on my phone and do the same on my chromebook. Event notifications wouldn't work on my phone, but I did receive an audio and pop-up window notification on my chromebook. Reminders worked fine on chromebook, but still didn't wake up my screen on my phone.
 
The last I tried was installing third party apps - Glimpse Notifications and Wake Up Screen. Both initially worked for one day and then they didn't. Now I'm back to square one.
 
I only have two other apps that I have setup the same way as Google calendar for notifications which are Google Messages and Ring and they work fine. I'm assuming that the software update only affected the calendar. Any help would be appreciated.
 
Thanks,
Darren
1 REPLY 1
Highlighted
Explorer

Hello Darren

 

check in settings that the Google Calendar and also stock calendar app are not battery optimized and they are allowed to run in the background. Any battery saving setting should be disabled for these apps. 

 

Hopefully this will help

 

Robert 

Top Liked Authors