Open search

GearVR - oculus not starting


Hi there, copied my topic from reddit


I posting here because I hope there's someone who found fix for same issue. So here we go:


I have month old galaxy S10+ exynos UK version. Phone is snappy in VR and battery life is amazing. I like to use gear VR from time to time, but I have discovered that Oculus VR start only 1st time after reboot. When I take it out from GearVR and try again later, phone is not detecting that it's inserted to gearVR headset. All I can do to make it work is to reboot phone , then will start once. This is what I tried so far:




* Tested my headset with spare S8 and it works every time.

* Reinstalled oculus services etc...

* USB settings in developer options (USB debugging ON/OFF)

* Cleared cache

* Checked if Oculus services are not put to sleep for battery saving.

* Hard reset phone




# Workarounds:


# 1. Reboot your phone and as I mentioned above and Oculus will start normally. Repeat the process before each use.


# OR


# 2. Change screen timeout in phone settings to 5 min, Insert your S10 in to headset for exactly 2 minutes, Oculus will start!

New Member

I was hoping for a fix as the same is happening on my S10? 

Works after a restart...


@Goodrockin wrote:

I was hoping for a fix as the same is happening on my S10? 

Works after a restart...

Did you try changing screen timeout to 5min and leaving phone for exactly 120 seconds?

I just want to prove it's the case for all headsets and s10 lineup.


Please could you guys provide:



Model of phone

Model of headset


This will hopefully speed up oculus/Samsung patching the bug.


My is:
UK unlocked (from Samsung directly)
Galaxy s10+
Gear VR SM-323 with 3dof controller

I'm having the same issue with my galaxy s10. When plugged in the 1st time it works, but it doesnt the second time which is when I'll reboot and it work. I'm going to try the 5 min display 2 minute wait method and get back with you. Btw I'm in the u.s


Update I set the display to 5 mins and left the my phone in the headset for the full length of time but still no results. So I have to restart the everytime I use.  Again I'm in the u.s. running snapdragon. 


P.s. also I've noticed on a couple of the apps the screen will freeze occasionally so I just press the back button then resume the app and it works. In case someone come across this issue


 Are you on June update? 

If restarting phone help then its 100% software issue that will be patched SOONER OR LATER 

My exynos behaved slightly different because 120seconds did the job without reboot, but like you said  you own snapdragon which is based on diferent kernel.

Top Liked Authors