Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Video playback from SMB stops after 10-15 mins

(Topic created on: 27-03-2019 03:37 PM)
986 Views
sephiroth_vg
First Poster
Options
Hey guys! I am having this weird issue where any Video I try watching over SMB from my NAS crashes after 12~20 minutes and returning me to the file directory. I'd normally pin it down on a device issue/network issue however it is occurring ONLY on newer Samsung devices (S9+, and S10+). On my other myriad of devices like a Samsung S6Edge Plus, S7Edge, LG V20, Samsung S5, and Blackberry Keyone this issue doesn't happen and every video plays back flawlessly.
This all started when I upgraded from my S7Edge to a S9+. Since then I changed the Router (Netgear R7000 to a Netgear 8500), bought a new Modem (Old Cable modem to a Fritzbox Cable modem) however it seems to have not changed anything regarding my issue on the Samsung devices. The routers are running DDWRT and I've also had this issue with another NAS as well as stock router firmware.
I first thought it was an issue with MXPlayer Pro but after a lot of communication back and forth and showing the developers Logcat dumps from my phone, they narrowed it down to being caused by my Device. I tried hard resetting the S9+ a couple of times to see if that would help but it didn't change a thing. It's not an issue with the WiFi signal either as the videos playback without any issues on other devices. I had hoped that getting the S10+ would fix this and that it was just an issue with the S9+ but it turns out the S10+ has it as well.
I had tried other video players like VLC and other file explorers like ES File Explorer, ASUS File explorer, and Total Commander on the S9+, while on the S10 I've tried ASUS File Explorer and EStrong coupled with MXplayer.
In the S9Plus, even on fresh hard reset, the preinstalled apps updated and only ASUS File explorer and MXPlayer installed the videos would crash after ~15 Minutes.
On the S10Plus, a couple of things I noted was that in the beginning, when I got the phone, ASUS File Explorer used to be able to play back videos (>30 Minutes) but once I even updated the basic preinstalled apps which came with the phone it would stop loading videos when I'd press on them ( I can still access the NAS and see the file structure etc). So I switched over to EStrong through which I can now load the videos and play them fine until they crash back to the file directory 10~15 Minutes in.
I am at my wits end with this, The S9Plus was RMA'ed 4 times till Samsung agreed to refund me and I bought the S10+ with the refunded money.
P.S I've also disabled battery/power saving for the file explorers and MXPlayer, as well as put the phone in performance mode. Without this, the videos would play back with a lot of buffering and choppiness (On the S9+ they'd sometimes load for 20 minutes only to playback for 5 and then load again)
All phones are EU Versions except the LG V20 which is American!
Can someone PLEASE help me fix this issue as I've been constantly going nuts trying to make it better! Ask me any info u'd like and I am willing to try everything short of rooting the phone and voiding the warranty!
0 REPLIES 0