Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

S10e , second sim card loosing network signal

(Topic created on: 02-02-2020 08:56 AM)
Chosin
First Poster
Options
Galaxy S10 Series

Hi  I have a s10e . I have two sim cards fitted . Last week for no apparent reason the second sim card which is on the lyca mobile network began to loose network signal. It also keeps asking to input the sim password. When the sim password is entered it takes about 30 seconds before it accepts the sim password. The network for the second sim then shows no signal. I cannot use the second sim for texts ,calls or data. I have cleared the memory cash. Removed the sim and refitted it , changed the sim slots. The sim toolkit app has also disappeared from the phone for the second sim.

Any idea what is going on 

2 REPLIES 2
BandOfBrothers
Superuser II
Superuser II
Options
Galaxy S10 Series

Does the sim card work ok in another phone @Chosin  ?

 

If it does then my suggestion is to let a Samsung Experience Store  / Samsung Service Centre have hands on with it.

 

 


Current Phone > Samsung Z Fold³ 5G.

0 Likes
Chosin
First Poster
Options
Galaxy S10 Series

The sim card works correctly in a HTC phone I have. 

I put the sim card into a friends s10 dual sim with there sim still installed and the same thing happened to their phone . 

The sim took a long time to unlock after the password was inputted and as soon as it went by that screen the signal dropped on both of the networks. 

The other sim came back but the lyca sim stayed at no signal 

Just strange that it was working fine for months then all of a sudden this problem arises .

Anyway thanks for advice I will have a look for one of those stores  

0 Likes