What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Original topic:

"Moisture has been detected" Error (Samsung Galaxy S10 5G)

(Topic created on: 26-05-2020 05:17 PM)
First Poster



Sorry if this topic has been covered multiple times before, but I believe this is a slightly more difficult case.


I have had the "moisture detected" error on my phone for about 5/6 months now and I can't fix it. I never got it wet in the first place. I've tried pretty much everything that the internet has suggested to try and fix it but no luck. Below is everything I have tried:


- Waiting for it to 'dry' (even though it was never wet or damp)

- Restarted the phone multiple times

- Updated the phone

- Started the phone in safe mode

- Cleared the Cache and the Data

- Cleaned the port on the phone and charger

- Factory reset

- Tried different USB-C cables

- Deleted apps

- Inserted cable as phone starts up


I have tried all these things multiple times but even after 6 months, I still get this error. I can only charge my phone wireless which isn't always good. I am better than the average user with technology and phones so I have tried to look pretty deep into this but sadly, no luck.


My phone is not under warranty so I was hoping to find a solution without having to spend a small fortune on repairs or a new phone.


Any advice/ideas would be great!


@Dranadade: Sorry to hear that you're experiencing this issue. It does seem that you have covered most of the relevant bases, troubleshooting-wise, so I'm not sure what else to suggest if the issue has persisted. If you open the Samsung Members app and go to Get Help > Interactive Checks > USB, and follow the on screen prompts, does this return any errors? If so then this is a hardware issue, and the phone will need to be inspected and repaired by an authorised Samsung Engineer. Alternatively, if you haven't already attempted it, try returning the phone to its default settings by going to Settings > General Management > Reset > Factory Data Reset > Reset Now. This will remove any personal data, so please ensure that you create a backup prior to performing this step, as per the prompts that are provided at the reset stage.