Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Do Not Disturb/ Alarm

(Topic created on: 12-03-2021 08:40 PM)
MC2002
Journeyman
Options
Hi,

Can anyone tell me why my alarm worked perfectly and would wake me up even though its set before my 'do not disturb' switches off & now my phone has updated (within the last few days) my alarm now no longer works properly. 
For while my alarm actually 'goes off' I am unaware of this fact anymore as the 'do not disturb' is actually hindering it from vibrating.

As you can see from the image the alarm is set as an exception. 

image

This along with the fact I can now also no longer get rid of the camera shutter noise, which for me is the equivalent of nails being drawn down a blackboard (even though my system noise settings are to the far left and switched off) basically means that in a few months time, when I look for a new phone galaxy is not going to be my priority phone.

Very annoyed to say the least. 
27 REPLIES 27
MC2002
Journeyman
Options
Thank you for this, I will will try it tonight
& that's a lovely picture by the way
0 Likes
MC2002
Journeyman
Options
Update:-
after deleting and re-enabling everything via bixby (which I loathe), as per your suggestion, for the last couple of nights,
I have finally switched Do not disturb off completely as my alarm is never vibrating and all I see when I finally wake up is 'missed alarm'
which after having used the Do not disturb function for many years with no issues is highly disappointing to say the least 🙁
especially as it was one of my most favourite functions to use
0 Likes
MC2002
Journeyman
Options
No I did not receive a solution, my Do not disturb is still broken as far as I'm concerned.

So I am not marking this as solved, until sometime actually fixes my phone.

Therefore stop asking me to mark it as solved.

Screenshot_20210303-083208_Yahoo Mail_6396.jpg

0 Likes
zkarampa
First Poster
Options

I think I found the problem/solution (at least it seems to be working for me). For some reason on the notifications seems to not be allowed when on do-not-disturb mode (although I clearly specify alarms).

The way I fixed it is to go to the notification preferences of the clock app and change them to override do-not-disturb. App info -> Notifications -> Alarm and timer alerts -> Ignore Do not Disturb (change it to on)

Screenshot_20210312-203130_Settings.jpg

Screenshot_20210312-203135_Settings.jpg

Screenshot_20210312-203145_Settings.jpg

   

I hope it helps.

0 Likes
MC2002
Journeyman
Options
Apologies for not responding sooner but I found the email alerting me to a new post in my spam box yesterday.

Thank you for sending this to me and I tried it last night, my alarm still did not work 😕.

So I've now given up on it ever doing so again while I have the Do not disturb feature on.

🤷🏼‍♀️ so much for this new UI begin more intuitive 🙄, its done nothing but cause me hassle
0 Likes
zkarampa
First Poster
Options

Apparently my solution worked for a couple of times (when testing) but then it stopped again 😞

I've noticed something weird... I tried to uninstall clock updates, in case the bug is in the latest version of the clock app. However after uninstalling the updates, the app seems to be on the latest version (according to galaxy store).

What version of the Clock app do you have ? I have 12.0.05.7  (after uninstalling)

Also since I uninstalled clock updates, all my tests seems to be working. We'll see when the real life scenario comes how it will behave...

0 Likes
zkarampa
First Poster
Options

OK, I did a bit more testing...

I noticed the following:

When the alarm rings, it uses the sound level of the notifications volume. So, regardless of whether you have do-not-disturb or not, if the notification volume is zero, there is no sound when the alarm rings (see pic)

Screenshot_20210322-195733_Settings.jpg

Now, if you have the 'Vibrate' or 'Mute' sound mode, the level of the notifications volume automatically goes to zero. The only way to have volume other than zero is to have 'Sound' mode (see pic)

Screenshot_20210322-200855_Settings.jpg

I'm pretty sure that in the past when I had it in 'Vibrate' it didn't change the volumes, it just didn't rang.

I usually have my phone on 'Vibrate', so the alarm doesn't ring... 😞

Also I have various Bixby routines which changes the notifications level during night, before bed, etc, so again no alarm... 😞

I need to change my settings and routines to actually have my phone on 'Sound' mode in order for the alarm to ring.

Hope it helps this time.

 

 

 

 

 

 

 

 

 

 

 

 

0 Likes
MC2002
Journeyman
Options
I've only ever had my phone on vibrate mode for everything, as I can't stand the horrible 'beeping' noises phones make

"I need to change my settings and routines to actually have my phone on 'Sound' mode in order for the alarm to ring." - but this should not have happened, the settings should have been left as they were as they worked, why should we have to find work arounds that are long winded and will cause further issues down the line 😕
0 Likes