Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

Bluetooth cuts off as soon as device locks

(Topic created on: 11/03/19 21:42)
Gazza4
First Poster
Options
Galaxy S10 Series

Spotify stops playing through any bluetooth speakers as soon as the s10+ goes to sleep.

 

Starts again as soon as you loft the phone

 

Disabled battery optimisation for spotify. No change 

0 Likes

1 Solution


Accepted Solutions
Solution
Richmar83
Explorer
Options
Galaxy S10 Series

I had the same issue on my S9 following the One UI update when it kept stopping Deezer then when unlocked it started gain.

It's down to the sleeping apps function, so when screen turns off then the operating system puts the app to sleep.

 

If you go to device care -> battery -> 3 dots top right, then 'sleeping apps' option. Remove spotify from list and all should be good.

View solution in context

9 REPLIES 9
Solution
Richmar83
Explorer
Options
Galaxy S10 Series

I had the same issue on my S9 following the One UI update when it kept stopping Deezer then when unlocked it started gain.

It's down to the sleeping apps function, so when screen turns off then the operating system puts the app to sleep.

 

If you go to device care -> battery -> 3 dots top right, then 'sleeping apps' option. Remove spotify from list and all should be good.

View solution in context

Colin19
Troubleshooter
Options
Galaxy S10 Series

@Gazza4 wrote:

Spotify stops playing through any bluetooth speakers as soon as the s10+ goes to sleep.

 

Starts again as soon as you loft the phone

 

Disabled battery optimisation for spotify. No change 


Sorry can’t help on this one, I have no issues when screen locks. Good luck 

0 Likes
Colin19
Troubleshooter
Options
Galaxy S10 Series

@Richmar83 wrote:

I had the same issue on my S9 following the One UI update when it kept stopping Deezer then when unlocked it started gain.

It's down to It the sleeping apps function so when screen turned off then it put the app to sleep.

If you go to device care -> battery -> 3 dots top right, then 'sleeping apps' option. Remove spotify from list and all should be good.


Just had a look, think that will solve the issue. 👍 put Spotify on the list, turned off on lock screen, removed from list all back as before. Good shout out. 

0 Likes
Gazza4
First Poster
Options
Galaxy S10 Series

This did not solve the issue 

0 Likes
Matt1412
Apprentice
Options
Galaxy S10 Series

I've seen on another thread if you go into settings and search for 'optimise battery usage' and select it from the top of the menu, then select 'all' and deselect the bluetooth. 

 

I had the same problem and have nust found this method, haven't tried it out yet but am optimistic as its doing my head in! 

0 Likes
Richmar83
Explorer
Options
Galaxy S10 Series

The method I posted before resolved it for me. I've just looked and Bluetooth is included on my Optimise Battery Listing (so is set to powersave), and i don't have the dropout issue anymore. 

0 Likes
Matt1412
Apprentice
Options
Galaxy S10 Series

Hmm, I had a look at that menu and spotify wasn't there on mine 💁‍♂️ God knows, I'll see what happens tomorrow fingers crossed it won't cut out 😂

0 Likes
Mikee101
First Poster
Options
Galaxy S10 Series

If you have followed the other reply by removing Spotify from sleeping apps - but Spotify is already not in sleeping apps...

It's probably the 'Adaptive battery' setting.

Turn this off in Device Care > Select Battery > Settings - (the 3 dots in the top right corner) > disable Adaptive battery.

 

This has worked for me.. hopefully it works for you.

 

Cheers,

Mike

ramprat99
First Poster
Options
Galaxy S10 Series

This worked for me. Thanks!

0 Likes