Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

An SD card was removed unsafely. To prevent your phone from restarting... notification

(Topic created on: 18-05-2021 11:46 AM)
utopic
Explorer
Options
Galaxy S10 Series

Ever since the big update to Android 11 / One UI 3 I've been getting the

"An SD card was removed unsafely. To prevent your phone from restarting unexpectedly, save unsaved data and restart your phone"

notification, many times a day.

 

After the update and prior to having this error, I have not messed with the card or the SIM, connected the phone to the PC, dropped the phone or done anything that might lead to this - the card had been inserted months ago in the phone and left untouched.

 

I don't seem to have any issues using the phone, can access the card OK for both reading & writing. 

I can't turn the bloody notification off and it's driving me up the wall as I'm getting it even during the night.

 

Have tried:

  • restarting the phone
  • unmounting the card and restarting the phone
  • physically removing and card from the phone and putting it back
  • removing the card and error checking it (in windows, using a card reader)
  • copying the card contents to the PC, formatting the card in the phone, then copying the contents back (via the windows file explorer)
  • getting into the recovery mode (which was pain the *ss) and wiping the dalvik cache
  • full/factory reset

The model # is SM-G970F/DS, kernel version is 4.14.113-20607146, latest available updates are installed, phone is stock, non rooted, non carrier locked.

Any suggestions?

179 REPLIES 179
36bits
First Poster
Options
Galaxy S10 Series

Made this change 24 hours ago and, so far, no notifications. For others: find the 'One UI Home' app in 'Settings->Apps', tap 'Permissions' and then allow 'Files and media' and 'Contacts'.

0 Likes
utopic
Explorer
Options
Galaxy S10 Series

I have tried this yesterday and it took a while for the notification to appear, but it did appear in the end, so it's not a fix for me.

 

I'll have to wait for the next software update.

0 Likes
cjvonhelmut
Explorer
Options
Galaxy S10 Series

yep, going to confidently say the software update fixed it since mine is better after updating, and now it sounds like others are corrected too...

for what it's worth, mine didn't automatically update, I had to go to settings and click on 'software update' for a couple of days until it let me update (due to server load)...so maybe keep checking the settings and manually trying to update. 

 

smell ya'll later

0 Likes
FUXXY
Student
Options
Galaxy S10 Series
Go to settings>apps> find one ui and look at the permissions for it
0 Likes
FUXXY
Student
Options
Galaxy S10 Series
It's been a few days and I haven't seen the message
0 Likes
FUXXY
Student
Options
Galaxy S10 Series
It's to do with one ui permissions change them
0 Likes
FUXXY
Student
Options
Galaxy S10 Series
It's a setting in one ui app look for the permissions and allow
0 Likes
FUXXY
Student
Options
Galaxy S10 Series
Try going to settings apps one ui application look for permissions and allow everything
0 Likes
FUXXY
Student
Options
Galaxy S10 Series
Setting > apps> one ui > permissions set it to allow everything
0 Likes
FUXXY
Student
Options
Galaxy S10 Series
One ui permissions set to allow for media and storage
0 Likes