Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

SMS not using the default sim card

(Topic created on: 24-08-2021 07:27 PM)
Members_nUwmUNj
First Poster
Options
Galaxy Note20 Series

I have a note 20 5g and for some reason my SMS app does not use the selected default sim card selected in settings. This happens on my old numbers, that I already had on my old phone. They use sim2, my work phone even if i have sim1, my personal sim selected as primary. When i change the sim in message settings it works only until i close the app then it goes to sim2 again. With the new numbers, that I introduced after I changed the phone it works just fine. The ones I had does not.
This happens for for messages only, calls and data is just fine.

Also, everything is up to date so there should be no problem there and I have al the necessary carrier settings installed on my phone.

0 Likes
2 REPLIES 2
AndrewL
Moderator
Moderator
Options
Galaxy Note20 Series

@Members_nUwmUNj: That's a strange one. For clarity, have you selected SIM1 as your preferred SIM in Settings > Connections > SIM Card Manager? If so, is SIM1 selected as your preferred Mobile Data option? This is just to ensure that the messages aren't converting to MMS format, and reverting to SIM2 to accommodate this. It might also me worth checking the storage location of you contacts via the Contacts app > 3 lines > All Contacts. If your old number are stored on SIM2, this might be why the issue is occurring. 

0 Likes
Members_nUwmUNj
First Poster
Options
Galaxy Note20 Series

I have no numbers on any of the sims. All my numbers are on google, both new and old. And sim1 is selected as preferred for all services: Mobile Data, Calls and Text Messages.

0 Likes