Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Awful Battery Life

(Topic created on: a month ago)
guinnsquirrel
Journeyman
Options
Galaxy Note20 Series

Hello,

I am new to the Samsung Galaxy Note 20 Ultra. Love the device. I am using it in dual-SIM mode, with two active connections. However, I am getting awful battery life... less than 1 day.

 

I have disabled:

  • Always on Display
  • Refresh rate is set to 60Hz
  • Background apps are put into sleep

 

What shall I do?

0 Likes
9 REPLIES 9
Mitzzz999
Hotshot
Options
Galaxy Note20 Series
How long have you had the phone? If its less than a week then the phone battery is still going through optimization settings for your usage.

Brightness control can impact battery life. Turn off NFC and Bluetooth if you do not need them on.

You can check battery usage in settings too, to see what exactly is using up your battery life.
0 Likes
guinnsquirrel
Journeyman
Options
Galaxy Note20 Series

Hi,

Thank you for your response. The phone is about 3 weeks old. However, I did perform a hard reset two days ago (long story). Will wait a week and see how its performing, I guess. 

 

AndrewL
Moderator
Moderator
Options
Galaxy Note20 Series

@guinnsquirrel: if you do continue to experience battery life issues, then please charge the phone to 100%, use it as you would normally for 24 hours, then head to Settings > Battery and Device Care > Battery > Tap on the graph > Select 'Since Last Full Charge' and check the list of apps and features at the bottom of the screen to see if anything is using an abnormal amount of battery. If you do see anything that's draining your battery significantly, then tap on it, select 'Limit Usage' at the bottom of the screen, and place it into Sleep or Deep Sleep, depending on your preference. In the meantime, please check out the tips below to improve your overall battery life.

- Shut down all background apps when not in use via the Recent Apps button
- Settings > Connections > More Connection Settings > Nearby Device Scanning > Off
- Turn off Wi-Fi, Mobile Data and Bluetooth when not in use
- Head to Settings > Battery and Device Care > Battery > Power Saving Mode > On, and check the additional options below
- Go back and select More Battery Settings > Adaptive Battery > On > Enhanced Processing > Off.

guinnsquirrel
Journeyman
Options
Galaxy Note20 Series

Andrew, 

Your feedback is awesome. Thank you for sharing.

Looking at my battery usage, I have found two (potential) culprits:

Screenshot_20210916-170542_Device care.jpg

 

Your Phone Companion and Garmin Connet do hogg the phone alot 😞

0 Likes
AndrewL
Moderator
Moderator
Options
Galaxy Note20 Series

@guinnsquirrel: No problem. If you place these apps in the Sleeping or Deep Sleeping Apps section, it will limit their background usage, and should improve your battery life. I can see that your Note 20 is currently learning your usage patterns, so you should see further improvements over time. 

0 Likes
BandOfBrothers
Superuser II
Superuser II
Options
Galaxy Note20 Series

@guinnsquirrel 

 

If like me you don't use 5G then turn that Off in Settings then Connections and you should see a usage improvement also.


Current Phone > Samsung Z Fold³ 5G.

0 Likes
Niknak89
Explorer
Options
Galaxy Note20 Series
Battery life is surprisingly poor which is a massive shame. Download good guardian from galaxy store. Has apps to monitor battery and you can improve functionality
0 Likes
guinnsquirrel
Journeyman
Options
Galaxy Note20 Series

Thank you all for your help and guidance. I seem to have resolved the issue (thankfully):

* Switched off Samsung 'Find My Mobile'. Googles service is just as helpful (IMHO).

* Disabled 5G.

 

Now I have a phone which can last me well over 1.5days it seems. Hurrah!

0 Likes
Niknak89
Explorer
Options
Galaxy Note20 Series
I never got 1.5 days when the phone was brand new
0 Likes