Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

Telemarketing Calls Ringing Through this Month when Do Not Disturb Turned On

(Topic created on: 07/07/20 22:12)
MWeiss
First Poster
Options
Galaxy Note10 Series

Up until this month began, Do Not Disturb effectively prevented telemarketing calls from ringing through on my Note 10+. Only people on my contact list could ring through.

My phone had an update about a week ago.

Several times in the past week, my phone has rung and it was an out of state caller not on my contact list. These calls disrupt recording sessions and meetings. 

Normally, only a family member with a serious emergency is able to ring through, but I cannot have my phone ringing with telemarketers. I will have to put it in Airplane mode, but then family can't reach me in an emergency.

Did the last update break this Do Not Disturb feature?

0 Likes
4 REPLIES 4
CrazyTom2k2
Superuser I
Superuser I
Options
Galaxy Note10 Series
Hey there MWeiss!

Sounds like a strange issue you're having there. I haven't got the slightest clue about if DnD's broken, but I wanted to suggest maybe ringing your carrier/network and seeing if they can block the telemarketing calls from their end, or maybe opt in to the Telephone Prevention Service. Sadly, that won't fix any issues with DnD, but hopefully it's a good way to mitigate telemarketers. Either that or tell them you're gonna "find them and kill them" 😁.

All the best,
Tom 😉
MWeiss
First Poster
Options
Galaxy Note10 Series

I'm using DnD because my provider, Verizon, charges for the spam blocking service.

 

It worked perfectly until this past week, when my phone received an update. Now the feature is broken. I nearly got a contempt of court citing while in court the other day because my phone, which never rang audibly before, rang out loud during a deposition. Now I have to use airplane mode, but cannot receive emergency calls from my family. What's the point of having a phone?

 

I just want Samsung to fix what the update broke. It feels like a conspiracy to allow telemarketers to bother us cell users.

0 Likes
CrazyTom2k2
Superuser I
Superuser I
Options
Galaxy Note10 Series
Ahhh, ***** you, Verizon!

The only other suggestion I've got is to check you DnD exceptions, because I'm wondering if you've got the Repeat Callers exception turned on (or if the update enabled it). Apart from that, I'm not too sure, sorry, but if your phone's broken to the point when it's ringing in a courtroom, sounds like Samsung could do with escalating that, and they might be able to help you out with some compensation. You might be best using the Live Chat option to speak to a Samsung rep, and they should be able to help (if you're anything like me, you might prefer to give Samsung a call, which you can also do from the Members app). The only other suggestion I've got is to Block Unknown Callers (By going to Phone>[3-dot-menu]>Settings>Block Numbers>Block Unknown Callers), but you won't get calls from withheld numbers this way.

I've had my fair share of telemarketers too, and a number of rude ways of dealing with them! 😊

Guessing as you're on Verizon, you're over in the US? I'm not sure if you guys have anything like the TPS we've got in the UK, but if so, maybe opt in and see if that helps at all.

Again, really sorry I couldn't do much more for you. But all the best, and stay safe,
Tom 🙂
MWeiss
First Poster
Options
Galaxy Note10 Series

I have Block Unknown Callers enabled, but it too stopped working last year, so I had to enable DnD, which worked absolutely. I could see the call coming in as the display would light up with the number, but the ringer was silent.

Under Block Unknown Callers, I don't have an option to block repeat callers.

Since that update, it's no longer silent. No one I know calls me during certain times of the day excepting a dire emergency. To have total strangers or robocalls ring through all of sudden is a huge problem for me.

0 Likes