Support

Open search

Samsung A40 Rear camera out of focus because it launches in macro mode

Highlighted
SOLVED
First Poster

Hello,

 

Lately my mother had a problem with her phone. When you start the camera, it opens in macro mode and is thus out of focus. If i click on the "normal" mode the problem disapear (of course...).

 

The thing is other programs like facebook, whatsapp, google lens,... which use the camera use the "standard" macro mode. Which makes them useless to use...

I have tried to:

  - check if there is any settings to change that

  - Delete all the caches and data of the camera app

  - Updates all the apps and OS

  - Install another camera app (same problem because my guess is they use the "standard" camera settings)

  - start the phone in safe mode

  - Factory reset the phone (thanks for the 1:30hours lost)

 

But nothing works. It is not a camera problem.

What are our options Samsung? Sending you the phone back for repair won't do anything because it's just a "base" software problem occuring after an update. 

Can't you make a fix for this? I have seen several post relating this issues but none mentioning that the app start natively in macro mode. But noone got a workaround for it anyway.

 

Thank you for your answer(s) and have a nice day

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

The red mode is, infact the normal camera mode. The one to the left is ultra wide angle. There is no macro mode on the a40. It seems to me there is a hardware or software issue affecting the main camera sensor. You should call Samsung support and you may unfortunately need a replacement if it's a hardware issue

View solution in original post

5 REPLIES 5
Highlighted
New Member
hi if the problem started after an update have you tried going back to the last software version check the camera see if this sorts it and then try the update again to see if this works bit off a long winded process but may work.
Highlighted
First Poster

Unfortunatly after the factory reset, the problem was still there. My mom told me that when she 1st got her phone it was fine, the problem started appearing around 6 months ago.

Do you know a way to revert the phone back to older updates?

Also, here is a picture of the root of the problem when we 1st launch the camera app. It always starts in the mode highlighted in red. Also something i forgot to mention is that with the other mode (left of the red circle), we cannot zoom in the picture, it automatically switch to this macro mode.

WhatsApp Image 2020-08-10 at 21.02.20.jpeg

 

Highlighted
GrandMaster

you cannot go back, or to be more precise you can if the bootloader has not changed (it probably has) and doing so potentially voids your warranty.

For this issue i really do not know what to advise, you tried everything. wait maybe not everything i remeber that there ws an opion called open camera in last mode used, but i cannot find that one perhaps enabling that will help you open in wide lense if you leave that lense when you close the camera


Archer
Highlighted

The red mode is, infact the normal camera mode. The one to the left is ultra wide angle. There is no macro mode on the a40. It seems to me there is a hardware or software issue affecting the main camera sensor. You should call Samsung support and you may unfortunately need a replacement if it's a hardware issue

View solution in original post

Highlighted
New Member

Hi  I have had exactly the same problem, did you get a solution to this please. Thanks