Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

My Samsung Galaxy A7 2018 won't turn on

(Topic created on: 19-11-2020 11:43 AM)
3428 Views
IzzaLee
Apprentice
Options

Hello! I need your help, please.

 

So what happened was: I have my phone at 2% while charging. I was using it with my mobile data on, and then suddenly it got turned off. I thought maybe it was just too drained so I was planning to just leave it at that. Then the "charging icon" (you know the circle with the 'lightning' + number% inside) showed up, but the problem is it's just showing the circle + lightning icon WITHOUT number%. So I got worried and tried to turn it on but it won't, tried to soft reboot but it won't, tried to do the same while connecting it to my charger but again it won't. When I tried to soft reboot it while connecting my charger, it just turned off, I mean the charging icon disappeared and then appeared again, and just that.

 

Please help! Thank you.

0 Likes
4 REPLIES 4
DAVESHADY
Pathfinder
Options
press power button and volume down button together..phone will start up..then turn volume to full then charge up then adjust your volume to what you want..I did the same as you was told by my daughter..it works...
IzzaLee
Apprentice
Options

I already did but it still won't turn on. I don't know what to do anymore.

0 Likes
AndrewL
Moderator
Moderator
Options

@IzzaLee: Do you have access to another charger that you can try to see if the issue persists? Alternatively, if you have a home computer, try connecting the phone via USB to see if you're able to establish a charge in this manner? If the problem persists, please reach out to our Help Desk via the link below, where an advisor will be able to assist you further, and arrange any necessary repairs. 

 

https://www.samsung.com/uk/support/contact/

0 Likes
IzzaLee
Apprentice
Options

I already did but it still won't. My last option was factory resetting it and I did, but it still won't turn on. If you charge it, it's still the same as what is showing on my original post.