Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Battery Drain on Galaxy A33

(Topic created on: 02-12-2022 06:57 PM)
4049 Views
Options

I have seen that all the users of the Galaxy A33 (including me) for months have problems with the battery.

 

On average we usually have a 4-5h SOT with a 5000mah battery. Some users comment that this problem arose from an update in June (I bought it in September).
 
Is it known if Samsung is working on a solution? I have already tried to do a hard reset but the problem persists.
 
Thank you!
0 Likes
3 REPLIES 3
Options

I have seen that all the users of the Galaxy A33 (including me) for months have problems with the battery.

On average we usually have a 4-5h SOT with a 5000mah battery. Some users comment that this problem arose from an update in June (I bought it in September).
 
Is it known if Samsung is working on a solution? I have already tried to do a hard reset but the problem persists.
 
Thank you!
0 Likes
BandOfBrothers
Samsung Members Star ★★
Options

Can you use your phone from 💯% to around 15% and then go into Device Care and into the battery section that's shown all the usage 

Screenshot that page with also using the scroll capture option to show All the apps including the phone's top status bar and then post that here so we can get a better handle on what's going on in your phone @Diego_LittleLion 

Thank you..

 


Daily Driver > Samsung Galaxy s²⁴ Ultra 512Gb ~ Titanium Black.

The advice I offer is my own and does not represent Samsung’s position.
I'm here to help. " This is the way. "

0 Likes
MordeL0L
Samsung Members Star ★
Options

Hello @Diego_LittleLion ,

First of all, this is the Samsung community forum in Spain, if you were looking for support in English I think you might be looking for this forum -> https://us.community.samsung.com/t5/Samsung-Community/ct-p/us

Anyway, it seems to be a problem related to the update, possibly one of the latest security patches.

Possibly they are already aware of this and will be working on a hotfix to fix it as soon as possible.

I was just going to say if you could try a soft-reset or a hard-reset, but you've already done that... you'll have to wait.

Best regards!