Support

Open search

What happened to registeration of products on the new account site???

Highlighted
SOLVED
Apprentice

Went to my account to find a complete mess and frustration. They've obviously revamped the site however, now I have absolutely no way to register my new SSD and to top it all my previously registered products have completely disappeared!

I have 3 products shown and those are just devices that connect to my account. Registerd - nope all registered products = 0 so not even my new phone I registered in October 2020 is there everything is lost including serial numbers etc.

 

What on earth is going on? Anyone know?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Apprentice

Well this is completely wierd and totally screwed up.

The problem is the UK site only. You go round in circles clicking links which return you to the same page. No registeration no products nothing especially when you gravitate to the members area where every link just returns you to the same page.

 

Reading some other threads I clicked on a link 

https://www.samsung.com/ie/support/warranty/

 

and there it was - "register product" 

Subsitute the "ie" for "uk" and you'll see it all disappears.

 

Once I got here I had to sign in again and that lead me to get all my products showing as before including the SSD I just registered in the members app.

 

Wow!! what a total screw up - I'm guessing they are separating the UK data due to Brexit finalising (possibly) and it is completely and utterly bug ridden !

At least for now I can access my proper data and info using the "ie" version

 

View solution in original post

8 REPLIES 8
Highlighted
Apprentice

Well not "obviously". I was on my PC logged in to my account via browser. There is no way to see my products - it appears though that Samsung have transferred the products from the Mysamsung accounts to their server but not showing that information to us.

 

I opened the app ( what happens if someone didn't have a smartphone - just bought a ssd and a microwave I wonder?)

and following your instructions found the registeration .. so thanks. I tried registering the phone I did in October and it told me it's already registered hence the above assumption of warranty server not communicating with our accounts.

 

I then went on to register the SSD I just bought and that appears now on "my products " in the app on my phone but it's not shown on the website when logged in so it's still a real awful mess. I really don't understand why they had to mess with it - worked perfectly before and always able to look up my products and see the warranty info.

 

Thanks for the heads up on the registering at least I can clunk my way to registering a product.

Highlighted
Apprentice

Well this is completely wierd and totally screwed up.

The problem is the UK site only. You go round in circles clicking links which return you to the same page. No registeration no products nothing especially when you gravitate to the members area where every link just returns you to the same page.

 

Reading some other threads I clicked on a link 

https://www.samsung.com/ie/support/warranty/

 

and there it was - "register product" 

Subsitute the "ie" for "uk" and you'll see it all disappears.

 

Once I got here I had to sign in again and that lead me to get all my products showing as before including the SSD I just registered in the members app.

 

Wow!! what a total screw up - I'm guessing they are separating the UK data due to Brexit finalising (possibly) and it is completely and utterly bug ridden !

At least for now I can access my proper data and info using the "ie" version

 

View solution in original post

Highlighted

Unfortunately when you click on the IE link now it now just redirects to the UK page regardles.

Really frustrating..

Highlighted
just type :
samsung.com/ie/members

directly into the browser's url

if you are getting the same problems please report it as I'm struggling to get them to acknowledge there's even a problem with the UK site
Highlighted

Ah yes that link worked thank you!

 

Yeah I've tried all day to get someone to acknowledge but they're just so useless...

Keep passing me back and forth to the same two departments. How is there NO website support.

Highlighted
because they are as you say useless.
the way I at least got the main product dept to deal with it was simply by telling them what the accounts guys insisted I tell them (you know the 0800 number they fob you off with claiming this is for account queries). That number is ONLY for queries related to accounts.samsung.com which as they correctly stated has no regional variants and is related to your actual sign in account you use for your phone .. syncing, passwords etc .
They have nothing to do with either the website or the members app.

The glaring omission here is that they provide no support whatsoever for this, as I'm sure you already noticed that when you go for help here you are asked what "product" you need help with.

Despite their fancy members app and site which makes it look like they have fancy support to go with it, it simply falls short as usual leaving people horribly frustrated.
Highlighted

Thanks! That worked for me this link https://www.samsung.com/ie/members/products/ instead of the UK one

Highlighted
please report the problem because they continue to claim nothing is wrong. the more of us that tell them will make it harder to try and blame us for "doing something wrong"
Top Liked Authors