Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Chg70-32 Purple ghosting using Freesync

(Topic created on: 24-04-2020 08:41 PM)
3865 Views
ValkyrieShana
Apprentice
Options

Hi,


I recently purchased the chg70 (32") (model number LC32HG70QQUXEN ) and while testing out freesync in some games I've noticed there is purple trails ghosting around objects when i moved the camera in game fast when the object has a high contrast difference to the background.


I've read this purple trail is actually known as reverse-ghosting / corona and it seems to have something to do with overshoot on the overdrive during freesync.


This doesn't happen when i use the Normal/Faster/Fastest overdrive options but when i turn on Freesync and the framerate is within the freesync range (e.g. fps fluctuating around 60fps). Only seems to happen with Ultimate Freesync setting, it might do the same in standard freesync but my fps is not in the smaller freesync range to test.

To my understanding my new monitor shipped with firmware 1061.2 or 1017.0 and the only firmware above this is the korean 1019.2 firmware for chg70-32, will this new firmware fix this overshoot on the overdrive in freesync or is there a firmware to fix this in the works? I'm still in the return period and I'd rather not have to return the monitor due to issues with freesync as it's otherwise a great monitor bar the fact that freesync 2 is not working correctly as advertised.

 

Thank you

 

 

Notes:
Seen particularly in Dragons Dogma on pc @1440p SDR in shadowy town, move camera around fast. Does same in Witcher3 according to another user. I can provide a recording in the next day of this if required.
Tested via both enclosed HDMI and DP cables from a Vega64 gcard, only appears to happen so far for me while inside the freesync range where the refreshrate is flucating in the info OSD menu.

25 REPLIES 25
vtec16
Student
Options

Sorry for my English, I'm from Spain and I don't speak English. I think I have found a solution for a ghost effect on the monitor, tested C32HG70 (firm korean 1022) but I think working in C27 and other similar panels.

 

EDIT:

SORRY, THE SOLUTION IS NOT CORRECT, MONITOR INFO DOES NOT DISPLAY GPU HZ.
BUT I HAVE ONE CURIOSITY:
DONT ACTIVATE GSYNC AND NO VSYNC AND THE GAME GETS TEARING, THIS IS LOGICAL.
ACTIVE GSYNC NVIDIA PANEL POINT 1, CHOOSE FULL SCREEN OR FULL SCREEN AND WINDOW AND POINT 3 ENABLED
START PLAYING AND I HAVE A GHOST EFFECT BUT NOT TEARING AND ITS ALL FLUID.
OUT GAME CTRL + TAB, NVIDIA GSYNC PANEL CONFIG DISABLED ONLY POINT 3.
ENTER THE GAME AND I GET NO TEARING, NOR GHOST EFFECT, BUT IT IS NOT THE SAME OF FLUID COMPARE, MONITOR INFO APPEARS FREESYNC 2 BUT FIX 144HZ.

 

ORIGINAL POST:

I tried AMD rx580 and NVIDIA 2080 with positive results, but better on NVIDIA.
In RX580 ultimate engine activated on monitor but not enable Freesync on AMD Control Panel
It works fine without a ghosting effect but with a small tearing, not much, can be resolved enabled vsync in the game options. Freesync2 HDR appears in monitor menu information and works fine, Resident Evil 3 tested in HDR game menu appears: "Freesync2"

Testing Sekiro, and in this game found ghost effect, it is because the game has 60fps blocked with internal vsync? its possible to use "standard engine" on monitor and the game works without ghost effect and perfect HDR, before this no possibly.

 

2080super is more easy, NVIDIA control panel, configure GSYNC:
Point 1. Enabled GSYNC FULL SCREEN mode.
Point 3: Activate the settings for the selected display model, first enabled when starts windows, after disabled before starts game or when the game is working. (*MAX FRAME RATE 3d config OFF )

In this way the games work perfectly in "ultimate engine" without tearing, without ghost, without the need to activate vsync .

 

https://youtu.be/0CWRQp0J3kI

 

Good Luck!

0 Likes
foresterr
Apprentice
Options

Sorry, but if your solution to fix ghosting due to Freesync is to turn off Freesync (it does not matter if you turn it off in the drivers or in monitor settings, off is off), then it's kind of obvious and not very helpful.

 

The monitor is actually running at static 144Hz decoupled from fps and that's why you don't get ghosting. If Freesync was working you would see the refresh rate in monitor menu changing.

vtec16
Student
Options

@FORESTERR:

 

SORRY, THE SOLUTION IS NOT CORRECT, MONITOR INFO DOES NOT DISPLAY GPU HZ
BUT I HAVE ONE CURIOSITY:
DONT ACTIVATE GSYNC AND NO VSYNC AND THE GAME GETS TEARING, THIS IS LOGICAL.
ACTIVE GSYNC NVIDIA PANEL POINT 1, CHOOSE FULL SCREEN OR FULL SCREEN AND WINDOW AND POINT 3 ENABLED
START PLAYING AND I HAVE A GHOST EFFECT BUT NOT TEARING AND ITS ALL FLUID.
OUT GAME CTRL + TAB, NVIDIA GSYNC PANEL CONFIG DISABLED ONLY POINT 3.
ENTER THE GAME AND I GET NO TEARING, NOR GHOST EFFECT, BUT IT IS NOT THE SAME OF FLUID COMPARE, MONITOR INFO APPEARS FREESYNC 2 BUT FIX 144HZ.

0 Likes
Musho
First Poster
Options

@CarlH any news on this? It's been 2 years since this issue has been brought to the attention. While dynamic overdrive would probably be the most elegant solution, I understand this isn't going to be easy to implement and I am not really expecting this from Samsung (although it would most definitely be awesome!).

 

What's frustrating however, is that the setting to change the overdrive strength is already baked in in the current firmware, but it's simply greyed out when using freesync. The only thing that would have to be changed, is for this existing option to be changable while freensync is enabled, and we would have a decent solution that's far far better than the current situation. We could then set overdrive's strength that best mathes the average FPS (and therefor hz) that a specific game is getting, or disable overdrive completely for those who would prefer that. This isn't a cheap monitor either, and not being able to change overdrive settings while freesync is enabled is simply unacceptable. Most VA-panel monitors from competitors do allow you to change overdrive settings.

 

This isn't the only place where this issue is being reported by the way. A quick google search shows this:

https://www.youtube.com/watch?v=0xLEBSJbsB4

https://www.youtube.com/watch?v=np6yxsNzj8E

https://www.reddit.com/r/Monitors/comments/9mp8mt/samsung_lc27hg70_heavy_overshoot/

https://www.reddit.com/r/Amd/comments/acfshx/overshoot_reverse_ghosting_on_samsung_monitors/

https://forums.blurbusters.com/viewtopic.php?t=4786

https://www.reddit.com/r/Monitors/comments/9qr62q/my_thoughts_on_the_samsung_c27hg70_after_a_month/

https://www.reddit.com/r/Monitors/comments/ahoq3t/has_the_ghosting_issue_been_fixed_on_c27hg70/

https://www.reddit.com/r/Amd/comments/9nuvom/chg70_freesync_monitor_firmware_10192_and_10200/

 

As you can see there are many many people running into this issue. And since overdrive settings are already configurable with freesync off, this means the feature is already implemented. It should be fairly trivial to allow us to change the strength or turn it off completely if we desire to do so while freesync is enabled. Please, Samsung, please, hear our plea!

 

Also, you're not only fixing this for a 2 year old monitor. This same fix should also be applied to newer Samsung freesync models.

AlexRZ
Student
Options
Still no response... I've contacted Samsung Korea and they've said they can't do anything....
IceDragon22
First Poster
Options

I too am having the same issues, it always is in dark areas.  This is VERY prevalent in Cyberpunk 2077 at night.  Just moving the mouse or the character gives you severe ghosting around any straight edge, it is enough of a problem that you have to turn off freesync to play.  It is just that bad.  It is getting to the point where I have left a 3 star review, with the added mention to not buy this monitor right now.  I just cannot recommend this monitor to anyone due to the overdrive issue.  I really wish Samsung would pay attention.

0 Likes