Support

Open search

860 EVO 250GB causing freezes on AMD system

Highlighted
SOLVED
Apprentice

Hello,

 

I bought 860 EVO 250GB 2.5" SATA few days ago (it came with the latest firmware) but there seems to be some sort of incompatibility with AMD 9xx chipsets. I have ASRock 970 Pro3 which has 970 NB + 950 SB, no additional storage controllers. I installed Windows 10 64 bit on it, then Magician, ran the "Performance Optimization" option there and left RAPID off since it says it may cause conflicts with AMD/AsMedia controllers. The problem is that Windows hangs at random times (it's not that often but it's annoying). For example, if it happens while there is a YouTube video running in the background, the sound continues and I can open a new tab in the web browser but the website won't load, I can't minimize the browser, if I click on the start menu button with the mouse, the menu won't come up, the task manager won't load when I press Ctrl + Shift + Esc and if I click on too many things everything freezes for 1-2 minutes, then goes back to normal. Also, everytime this happens, there are some CRC communication errors appearing in the SMART status. At first I thought it's a bad SATA cable, although I used the same cable with and HDD for 2 years and no such things occured, so I tried with another SATA cable and the result was the same. I upgraded the BIOS of the motherboard to the latest version, reset the CMOS, turned off any IDE legacy and power saving options for the storage, there is an option "AMD AHCI BIOS ROM" in the BIOS of the MB which also did not resolve the issue whether it's turned on or off.

 

What I found as an easy way to reproduce the issue is to run CrystalDiskMark, it hangs everytime at the 4KiB Q8T8 write test. Another scenario is to run virutalbox with ubuntu VM, for example - the PC hanged on both installation and update of ubuntu 16.04. Basically, you can reproduce the issue by putting the SSD on 9xx chipset AM3+ motherboard with FX CPU and then run CrystalDiskMark (I tested with version 6).

 

I also tested it on 2 Intel systems - one HP desktop PC with i3-3220  and one old HP laptop (with Intel T6570 CPU) and I didn't observe this issue on them. 

 

My specifications are:

ASRock 970 Pro3 (the first version not the R2.0 one)

AMD FX-6300 3.5GHz

11GB RAM DDR3 1333MHz

Samsung 860 EVO 250 GB SATA

Hitachi Ultrastar 2TB (HUA723020ALA640)

 

If you can come up with a fix, either new firmware or software workaround in Windows, it will be appreciated.

 

Regards,

Martin

51 REPLIES 51
Highlighted

Swagat, your experience on your mobo is consistent with my experience on an MSI B450 Tomahawk. In your case (using the SB950 chipset's SATA ports) and my case (using the B450 chipset's SATA ports), the Samsung 860 EVO experiences incompatibility (e.g., CRC errors, etc.). However, using the mobos' other (non-AMD) chips' SATA ports works satisfactorily. This has been reported many times on this forum. Caveat emptor!

Highlighted
Observer

Faced the same problem on my pc with MSI 970 mobo + FX 6300 CPU. Loads of ultra ata crc errors when I write data on this SSD drive. Later I've bought a Transcend 230s 512gb SATA SSD that doesn't have that issue at all. And now using Samsung 960 Evo on my Intel-Based Laptop without any issue as I can't return it anymore. Really wanted to use this SSD on my old pc. I think Samsung should have mentioned this compatibility issue on their product spec. 

https://prnt.sc/te9oo2

https://prnt.sc/te9pyj

Top Liked Authors