What are you looking for?

Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Original topic:

860 EVO 250GB causing freezes on AMD system

(Topic created on: 05/02/19 01:31)
Computers & IT



I bought 860 EVO 250GB 2.5" SATA few days ago (it came with the latest firmware) but there seems to be some sort of incompatibility with AMD 9xx chipsets. I have ASRock 970 Pro3 which has 970 NB + 950 SB, no additional storage controllers. I installed Windows 10 64 bit on it, then Magician, ran the "Performance Optimization" option there and left RAPID off since it says it may cause conflicts with AMD/AsMedia controllers. The problem is that Windows hangs at random times (it's not that often but it's annoying). For example, if it happens while there is a YouTube video running in the background, the sound continues and I can open a new tab in the web browser but the website won't load, I can't minimize the browser, if I click on the start menu button with the mouse, the menu won't come up, the task manager won't load when I press Ctrl + Shift + Esc and if I click on too many things everything freezes for 1-2 minutes, then goes back to normal. Also, everytime this happens, there are some CRC communication errors appearing in the SMART status. At first I thought it's a bad SATA cable, although I used the same cable with and HDD for 2 years and no such things occured, so I tried with another SATA cable and the result was the same. I upgraded the BIOS of the motherboard to the latest version, reset the CMOS, turned off any IDE legacy and power saving options for the storage, there is an option "AMD AHCI BIOS ROM" in the BIOS of the MB which also did not resolve the issue whether it's turned on or off.


What I found as an easy way to reproduce the issue is to run CrystalDiskMark, it hangs everytime at the 4KiB Q8T8 write test. Another scenario is to run virutalbox with ubuntu VM, for example - the PC hanged on both installation and update of ubuntu 16.04. Basically, you can reproduce the issue by putting the SSD on 9xx chipset AM3+ motherboard with FX CPU and then run CrystalDiskMark (I tested with version 6).


I also tested it on 2 Intel systems - one HP desktop PC with i3-3220  and one old HP laptop (with Intel T6570 CPU) and I didn't observe this issue on them. 


My specifications are:

ASRock 970 Pro3 (the first version not the R2.0 one)

AMD FX-6300 3.5GHz

11GB RAM DDR3 1333MHz

Samsung 860 EVO 250 GB SATA

Hitachi Ultrastar 2TB (HUA723020ALA640)


If you can come up with a fix, either new firmware or software workaround in Windows, it will be appreciated.




Computers & IT

EDIT  UPDATE: ======= I found the cause of the issue.===========

The Chipset drivers from ASUS and AMD.

In device manager, search for:

IDE ATA/ATPI controllers

Expand that you will find:

" AMD SATA controller "

Right click - properties - driver... Chose "Rollback Driver"

This should uninstall the AMD Chipset driver and install microsoft driver.


*If this does not roll back, you MUST uninstall ALL AMD drivers (It might be part of ATI or catalist  which include all kinds of package drivers). You have to find the AMD file in " Program Files " " Program Data " " Program Files 64 " .. you must have uninstalled all AMD software and manually find the AMD folder to remove/delete it.. You have to show all hidden folders in the folder options in controll panel. These files will linger and conflict to re install . 

I DID NOT unstall the drivers in Windows DRIVERS folder. BUT they could re install. IF they do you will probably have to force that windows driver to install or redo your OS.

(I don't know these tricks)


When doing this, for some reason (which shouldn't have happened, I must have deleted a windows driver) this crashed my system to the point Windows would not start up, even running a windows repair.

I had to buy another SSD to install fresh windows, just to re connect my (crashed) Intel SSD back to pull files I did not want to lose on a windows re install.

THEN I was able to fresh install windows on the Intel SSD, put all my files back from the PNY SSD.. then disconnect the PNY and add the Samsung 860 Evo and continue testing. 

So, fresh windows install on Intel SSD not connected to the internet.. no drivers installed. Connecting the Samsung and trying to get it to work. (Which it did!)


This is when I discovered the only driver or software I installed caused the Samsung issue, Chipset. 

It was not anything else but the chipset drivers.


If you use a AMD package or ATI package it will include a Chipset driver . If under ' IDE ATA/ATPI controllers ' you see " AMD SATA controller "... your doomed.  Roll back the driver and windows should install windows drivers.. problem solved.


This will then allow the drive to work faster with Samsung Magician and CrystalBenchMark. This should then work with fresh windows install.




I have spoken to Samsung 1800-SAMSUNG and chose 'Memory'.. and they confirmed that the benchmark scores using windows drivers are lacking by 50 - 100 MB/s.. but the sequential read and write is " about right.. could be better ".


So using windows drivers makes the drive not hang for 27 minutes to do the Samsung Magician benchmark test.. now it takes about 4 minutes.

BUT... not exactly what the drive potential could be. 


It is my conclusion to not recommend the drive price per performance when it is slightly nerfed by windows drivers .. when the chipset drivers must be uninstalled to USE the Samsung 860 EVO SSD and the 860 PRO ssd (I have tried both) on ANY AMD 990FX/SB950 chipset boards. 

I ended up refunding the Samsung 860 EVO 250GB  2.5" Internal Solid State Drive and bought the Samsung 860 PRO 250GB 2.5" Internal Solid State Drive.


I am going to refund the 860 pro.


There is not a reason to pay for the high proformance drive when you are nerfed by the windows drivers on this board.

ASUS/ASRock/Gigibite windows 7, windows 10.. all what I have read..

Since 2013 with the 840's to 2018 with the 860's.


WHY has this compatability issue not been corrected? There is no warning on the box, in the stores.. on the website.

There is no 'fix' for the issue.


I will NEVER EVER buy a Samsung Solid State Drive again.


I have an Intel SATA II

I recently bought a PNY CS9000 SATA III (cheap drive) to test with. (refunded)

Both drives worked perfectly fine on the AMD 990FX/SB950 chipset board with the AMD // ASUS chipset drivers.

------------ END OF EDIT -------------


I have an ASUS M5A99FX PRO R2.0 board. Chipset:990FX.

I tried

Samsung 860 EVO 250GB MLC V-NAND SATA III 6Gb/s 2.5" Internal Solid State Drive

Mfr Part #: MZ-76E250B/AM



And I tried,

Samsung 860 PRO 256GB MLC V-NAND SATA III 6Gb/s 2.5" Internal Solid State Drive

Mfr Part #: MZ-76P256BW

UPC: 887276247427

I am having the exact same issues as all of you have said.


27 minutes to do 'Performance Benchmark' in Samsung Magician.

Sequential : Read 47 Write 492 Random IOPS: Read 34,423 Write 35,400.



CrystalDiskMark 6.0.1 (64)/(32) both hangs/ is very slow to do the test.

After @ 30 minutes: CrystalDiskMark 6.0.1 x64 results:

-------READ / ------Write

Seq Q32T1 414 / 502.0

4KiB Q8T8 34.75 / 68.74

4KiB Q32T1 117.0 / 196.4

4KiB Q1T1 45.67 / 99.68

The scroes above were in the 'grey' ports of the SATA on the Motherboard. 1-4


Another problem is, if you go to

There is NO support for this drive.


Samsung Magician - System Compatability :



Under the current system environment, some functions in Magician CANNOT be run.
If multiple iterations of Read and Write are performed, RAPID mode may become inactive due to system internal errors on some of the AMD / AsMedia Controller or Driver.

 By the way, Samsung memory department "confirmed" the 860 Evo is a 3-bit.. which is TLC. the 860 Pro is 2-bit which is MLC.

Therefore, the Evo is not a MLC, it IS a TLC.

The Pro is MLC.



First Poster
Computers & IT
I have the same problem on a Gigabyte GA-MA790XT-UD4P motherboard with an AMD Phenom II X6 1100T. Luckily this motherboard comes with two "GSATA" ports that don't run from the AMD chipset, so moving the SSD from the AMD chipset-based SATA port to the GSATA port seems to have fixed it.
Computers & IT
Thank you for the reply.
Download CrystalDiskMark 6
just run it and call Samsung support, Memory. Tell the CSR your scores.

I did all the ports on my board. I got 2 of them that actually ran Samsung Magician and CrystalDiskMark. All the other ports on the board would take about 27 minutes to run both Magician and DiskMark.

When I explained to the Samsung Memory Tech Support CSR, he said the scores were about 100 lower then the hard drive average.
I even uninstalled the AMD drivers and used Windows. Same words were reported from Samsung CSR's.

With that said, I concluded the Samsung SSD would not work for my board.
I even had the 860 PRO version.

Right now, I bought a $22 ***** pos *SSD and the scores on 'certain' parts of that DiskMark test are higher then the Evo or Pro Samsung 860.

I then realized I'm keeping this *TLC pos SSD, I put windows 7 64 on it and its being used as I am typing this to you.
Seq READ........................WRITE
Q32T1 468.2..................473.3

Q8T8 248.......................252.2

Q32T1 246.9...................252.5

Q1T1 40.02....................91.89
15 chrome pages open, photos open. GPU-z open. downloads open.
I ran the DiskMark test again with all that open.

Not bad for a $20 SSD! ( TWENTY DOLLARS ) Microcenter
* Inland professional 120gb (piece of s**t) scores higher then my Evo or Pro (on some results of this CrystalDiskMark)

Another one I tested: PNY
PNY S900 120 GB (sale for $36 Fry's)
Magician PNY
486 read....446 write

860 Evo:
With Motherboard drivers
Same version CrystalDiskMark 6 (Not CrystalDiskInfo)

75 read....502 write.

HUGE ISSUE! Took 27 minutes to run both tests.. (EACH).

Windows Chipset drivers EVO:

VS pos *SSD

Did I mention the *POS SSD is while my motherboard drivers are installed NOT windows drivers?

So to use the Samsung SSD you have to use windows... and you don't get the full potential of the SSD so why are you buying it?
Why buy that type of SSD when it is nerfed to fully perform on this motherboard chipset?

AMD and SAMSUNG don't fix the issue.
Various complaints with the 850's, Samsung still does not sort out the issue with AMD.. visa versa.
First Poster
Computers & IT
For what it's worth, I'm running this on an Ubuntu 16.04 server with the 4.15.0 kernel. I don't really care about performance, as this is just the OS drive.

The troubleshooting in this thread led me to realize it's an issue when the SSD is connected to the chipset SATA ports, so swapping to a non-chipset SATA port (in my case, the additional Gigabyte SATA ports) is the perfect solution for me.
First Poster
Computers & IT

I have the same problem on my 


With 850 EVO works good but 860 EVO disk freezes and made crc errors.

Congratulations to Engineers from Samsung company !!!!!!

I am confused about your products.

Computers & IT
To put an end of the thread - I returned the SSD to the reseller. Just don't buy Samsung SSD if you will use the AMD SATA controller in the chipset :smiling-face:
Thank you all for sharing opinions and test results, I hope this thread will serve well to someone looking for an SSD.

View solution in context

First Poster
Computers & IT

My friend it is not solution.

Problem persist.


Big thanks to Samsung Engineers!!!!

New Member
Computers & IT

2019. Issue still present. 

My ASUS Sabertooth 990FX got CRC errors and freezes while making any SSD test.

Samsung Magican soft reporting that SSD Disk have LATEST firmwaqre RVT02B6Q.

Switched ASUS SATA6 controller to IDE mode. No more CRC errors but SATA speed reduced from 500Mbs to 300Mbs.

So I got close to ordinary HDD speed for SSD price! Will not reccomended Samsung SSD to anybody!!


Samsung, please correct this issue. It making harm to you reputation.





Computers & IT

I've had most of the same experiences as listed here.

I've previously had an older Gigabyte mobo with SB750, Phenom II x6 1100T, SandiskSSD and Win 7 x64 Ult. At some point I started getting weird freezups, and in retrospect, I think it started after updating some drivers, but I don't know which. At that time I was suspecting hardware, so I replaced the SanddiskSSD to new Samsung EVO 860 500GB.

When I started running tests, the speeds at SATA II (limitation for SB750) were showing fine, as below (this was with sorahci driver):

AS SSD on Gigabyte SB750.png




















CrystalDiskMark on Gigabyte SB750.png


I downloaded HDTune and also noticed that on every reboot, Samsung SSD had incrementing C7 errors (supposedly bad communication).


Long story short, I replaced SATA cables several times, checked different ports, installed fresh Win 10 (my system freezups stopped after installing Win10), replaced Gigabyte with new Sabertooth 990fx R2.0, updated to latest BIOS 2901, converted disk with MBR2GPT, updated all drivers... yet the C7 errors continue, but only on the AMD chipsets.


I'm now running fully in UEFI with secure boot, Win 10 Pro, Sabertooth 990fx R2.0, Phenom II x6 1100T, 8GB RAM (will update to 16GB soon), and Samsung EVO 860 500GB.


Since I've updated all my drivers for the new board, inadvertantly, my ahci drivers were updated to amd_sata and this caused extreme instabilities with the Samsung drive. Occasional frrezups, trying to start CrystalMark was extremely slow, so I gave up trying, and even running backups was failing. I switched the drive to the ASM1601 controller on the Sabertooth, and the stability improved and C7 errors were no longer showing up after reboots. However, even though AsMedia is a SATA 6 controller, it doesn't run in full speed. See below:

AS SSD on Asus Asmedia 1061.pngCrystalDiskMark on Asus Asmedia 1061.png


































I read somewhere that the way it's engineered into the motherboards its speed is limited by the PCI or hypertransport throughput (or something like that, can't remember exactly now). So that would make sense.

While I had the system disk and all other drives disconnected from AMD controller, I uninstalled the AMD SATA controller (with remove driver files), scanned for hardware changes and let Windows install the native storahci driver. I searched for any driver upgrades, but the storahci driver dated 2006 is the latest available for Windows (even Widows 10). 

I then swithed the Samsung SSD from AsMedia to AMD SB950 controller again and booted this time using the storahci driver. The stability is good now. No problems running any programs, but the C7 errors increment on every reboot again. However, when I ran CrystalMark and AS SSD, it shows overall speeds improved, but 4K write is crippled!! WTH?!?

AS SSD on Asus SB950.pngCrystalDiskMark on Asus SB950.png

I've ordered a replacement Samsung EVO 860 SSD from Amazon, and it arrived today, sitting on my desk. I'll soon replace it and return the other one back, but I have a feeling nothing will improve.


1) Does anyone have any idea why this TLC NAND Samsung SSD is running so badly on default Windows drivers under AMD SB950 controller?

I'm not even gonna try AMD drivers again. It's a disaster (not sure if by AMD, or by Samsung compatibility).


2) Can anyone with similar hardware configuration recommend a proven 500GB SSD I can use instead? Would MLC NAND be more compatible with SB950? I'm tempted to try the Sandisk I have, but it's a smaller drive, so even if it works well, there's no guarantee that when I buy the 500GB, it'll work exactly the same.


Thank you!

Computers & IT

Dude, I'm facing the same issue, this shi**y SSD (860EVO500GB) hangs my OS for about 1 minute randomly, have tried to use Windows10 and 2 Linux distros and it doesn't work, It's just cr*p.


I'm not sure if my issue is related to my platform (AMD / FX-8320), so I'll try your suggestion about uninstalling AMD' drivers, but anyway, if that fixes my issue, that's far away to be a solution, how the F*** is Samsung selling a Unit that doesn't work with one of the two majors CPUs manufacturers.

If your suggestion works (or not) in my system I'll edit my answer to let the users know.


I would like to return/refund the unit, but unfortunately, I reside México, and the SSD was bought from Amazon MX, but they sent me one from Amazon US, I've called Amazon MX and they asked me to call Samsung MX, I called Samsung MX and they told me that I should call Amazon MX back again to ask Amazon US to canalize this issue with Samsung US, because Samsung MX doesn't want to accept my warranty because the unit isn't from them (Holy f*ck, it sounds like a gangb*ng, and guess who's feeling to be Mia Khalifa right now >:v), so, Nope, I'm not going to frustrate myself trying to get a refund for a crappy product, I'm simply going to buy a HyperX (As I ever did, I know, my fault trying to explore another brand).


This is my first and last time that I ever buy a Samsung SSD, going back to Kingston HyperX.