Support

Open search

What is going on with eARC update for the soundbar HW-Q90R?

Pathfinder

Hi everyone,

 

I need some clarification, as to be honest the Samsung support staff are hopeless with knowing anything about their own products. 

I was on chat with support enquiring about the eARC firmware update for this soundbar, he replies to me saying it doesn't have eARC?! 

the whole reason I purchased it was because of this update, I have the LG C9 which is eARC!

 

if they don't provide this firmware update to allow it, then this soundbar is going back for a refund. 

863 REPLIES 863

Thanks a lot! I'm gonna try it tonight

Now I can play lossless dolby atmos demo files through Plex. I dont see Dolby Atmos in the soundbar display, I think I am playing true hd 7.1. If I play same video through usb drive it does not sound

Anyone got the full version string? And for those of you who got the update: what country do you live in? I live in Sweden and I can only see update "1008.0 126R" in the samsung smart things app.

1010.5 in Norway, we went straight from 1007.9 to 1010.5

@bjornland wrote:
1010.5 in Norway, we went straight from 1007.9 to 1010.5

same in France

Does anyone know yet how to test the update to see if it is working?

@SparksLegend wrote:
Does anyone know yet how to test the update to see if it is working?

Just did a test :

  • Nvidia Shield connected to LG C9 TV
  • TV connected to soundbar via HDMI eARC (enabled in TV settings with passthrough)
  • Played on Plex (from Nvidia Shield) 2 video demos, one True HD Atmos and other one DTS:X
  • and everytime the soundbar displayed the correct Atmos or DTS:X logo, with no sync issues.

So yes the soundbar is now fully eARC, this is confirmed. if it was not, we would never had the DTS:X logo appearing on the soundbar.

 

Cheers

I hope my Q900R TV will recive update for eARC...


@Marko81 wrote:

Plex app on my C9 didn't work for me either. It's constantly buffering when I tried to play movies with lossless Dolby Atmos track. When playing compressed Dolby Digital 5.1 it works fine. When I switched to Xplay app (you still need Plex server on PC) all problems disappeared and now I'm able to play lossless Atmos tracks (it's 5 days trial so you can try it and see if it works for you). So, I've installed Plex server on my PC, didn't change anything in the settings, just manually added folder with movies, installed Plex app on my C9 and that's it.

 

It's really easy to set everything but there is tutorial if something goes wrong for you.



https://www.howtogeek.com/252261/how-to-set-up-plex-and-watch-your-movies-on-any-device/


Did install Xplay and tried to play some losless MKV files but no Dolby Atmos or DTS:X on my soundbar. 

Plex and xplay are always buffering a lot and is difficult to watch content properly. It seems it doesnt buffer while paused

Top Liked Authors