Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 
Go to solution Solved

Sound Bar Q990C WiFi Disconnects

(Topic created on: 19-04-2024 07:34 PM)
2824 Views
IanCardiff
Explorer
Options

I have recently replaced my Samsung HW-Q90R with a Samsung HW-Q990C. One of the main reasons for replacing the older item were the problems with WiFi which continually disconnected, unfortunately I have the same problem having spent over £1000 on the new system.  I have not contacted Samsung as there is little point, they either do not answer or suggest there is a problem with my Wifi signal at home. There is nothing wrong with my WiFi I have many devices connected to WiF and they do not drop out at all. There is no doubt in my mind that this is a Samsung problem, not only have I had two Samsung systems with the same problem but reading on here, there are many others suffering the same problem. I do hope some one from Samsung reads this and comes up with some way of solving the issue. 

1 Solution


Accepted Solutions
Solution
Ibivfsbana
Apprentice
Options

In my case a I found there is an obvious fault with the 5ghz connectivity on this soundbar. Difficult to know whether it's a software or hardware issue.

I spent days trying to get the soundbar to connect and be reliably recognised by my S90C tv. 

However, I found that it is stable on 5ghz when using low 5ghz channel numbers. I encountered frequent disconnects whenever my WiFi was using the higher 5ghz channel numbers.

If you can, make sure your 5ghz WiFi is using the lower channels. I've not had any issues since doing this.

The one downside is if you have a router that automatically changes WiFi channel to reduce channel interface (such as Virgin's Smart One WiFi feature) , it will only be a matter of time before the soundbar goes offline and wont connect as it doesn't work well with high 5ghz channels. 

Hope this helps!

View solution in context

12 REPLIES 12
nyiroe
Apprentice
Options

Hello,

TLDR: Q990C seems not handling WPA3 well. Try WPA2 only.

Details: Q990C keeped disconnecting. I tracked down that it occured when my router restarted. All devices were connecting back, except Q990C. I had to reset and reconnect to SmartThings every time.

There a lots of forums there related to this issue. I read many hints, including let it connect only in 2,4 GHz / 5 GHz, set up it as SmartThings hub (bottom of the control), use only lower channels etc.

Finally I downgraded my WiFi to WPA2 only (not WPA2/3 mixed, because in this case it uses WPA3). Since then it seems stable.

I do not understand why Samsung won’t fix this in a brand new device, otherwise it is a great bar. But I have doubts next one will be Samsung if they won’t fix it.

IanCardiff
Explorer
Options

Thanks for this but my WiFi is already WPA2 so unfortunately that doesn't seem to be the answer in my case. As you say there are lots of different things to try but it is absolutely disgusting that Samsung seem to be doing nothing about a problem that lots of us are having. I'll keep trying all the different suggestions though. 

nyiroe
Apprentice
Options

Please share your circumstances.

  • Which vendor of your router?
  • Are you using any mesh?
  • WPA2 only then (are you sure it is not mixed?), but 2,4 / 5 GHz? Have you tried both?
  • I guess it can connect, how long until it drops? Do you need fully reset the soundbar then or restart / unplug?
  • For testing have you tried placing your router next to the unit to completely eliminate possibility of interference?

 

0 Likes
IanCardiff
Explorer
Options

My internet is via Virgin Hub 3, although I do not use the wireless part of this, instead all my wireless is on a Deco M5 Mesh. I am sure I am using WPA2 ONLY. I have tried 2.4 and 5GHz and have the same problem using either of them. It usually drops overnight, I usually have to do a complete reset, removing the speaker from the Samsung App and disconnecting the mains supply to the speaker, reconnecting then adding the speaker again. I have tried moving the Deco unit closer to the speaker but I still have the same problem.

0 Likes
IanCardiff
Explorer
Options

I have tried all the various 'solutions' to this problem but none of them work all the time. The unit connects and stays connected for a couple of days, sometimes less. It really is time Samsung sorted this out.

Solution
Ibivfsbana
Apprentice
Options

In my case a I found there is an obvious fault with the 5ghz connectivity on this soundbar. Difficult to know whether it's a software or hardware issue.

I spent days trying to get the soundbar to connect and be reliably recognised by my S90C tv. 

However, I found that it is stable on 5ghz when using low 5ghz channel numbers. I encountered frequent disconnects whenever my WiFi was using the higher 5ghz channel numbers.

If you can, make sure your 5ghz WiFi is using the lower channels. I've not had any issues since doing this.

The one downside is if you have a router that automatically changes WiFi channel to reduce channel interface (such as Virgin's Smart One WiFi feature) , it will only be a matter of time before the soundbar goes offline and wont connect as it doesn't work well with high 5ghz channels. 

Hope this helps!

IanCardiff
Explorer
Options

Thank you for yet another suggestion to this problem. I am unable to change the channels on WIFI router so unfortunately this isn't a solution for me. I have once again contacted Samsung who quite honestly don't seem to understand the problem, they seem to think that the unit disconnection from Smart Things is the problem  whereas the actual problem is it keeps dropping off WiFi and of course it then drops off Smart things. Apparently they have passed the problem on to a department that deals  with Smart Things problems, I have yet to hear anything from them of course. Why on earth there isn't an ethernet connection on the unit like there is on their televisions ? After all the two units are bound to be next to each other and if you have ethernet on one you may as well have it on the other. 

0 Likes
IanCardiff
Explorer
Options

The solution from Ibivfsbana seems to work! I have managed to connect my Soundbar to my Virgin hubs WiFi . This hub lets me chose which channel I use and upon selecting a lower number channel on the 5ghz band, the Sound bar has stayed connected for 5 days, the longest it has ever stayed connected. This is despite the Virgin router being a fair way from the Soundbar.