Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Samsung TV (QN90A) + Soundbar HW B650 en problem with dolby

(Topic created on: 01-07-2023 10:38 AM)
1081 Views
aleksander99
First Poster
Options

Hello.

I am currently having 2 problems with my soundbar.
First problem is Dolby Atmos sound format has delay of 100- 200 ms all of the time, and without using "dolby atmos" format, i am bound to PCM 2Channel audio format ( displayed on my soundbar when i press "i" button).
Second problem is, even though I have active licence for DTS: X. I cannot enable it anywhere.

My specs are:Screenshot 2023-06-24 155720.pngScreenshot 2023-06-24 155754.png
QE50QN90A Samsung NeoQled TV.
Samsung HW B650 EN soundbar
Windows 11 PC with AMD GPU.


My connection is set up like this:
PC ( AMD gpu) linked with HDMI 2.1 cable-(48Gbs) -> TV
TV linked with HDMI 2.0 ARC cable -> Soundbar.

First problem;

I have just recently found out  that I can use "dolby atmos" on my Soundbar since i got active licence, after trying out for a bit i quickly found out that i have about 100-200MS sound delay on all content.

What I have tried:
- Checked Audiosync option and in Tv option for audio delay, both are on 0. I have also tried setting both to max but problem wasn't fixed by it.
- Tried 2 different high speed HDMI cables ( TV - Soundbar), on both instances there is same amount of delay in audio.
-Tried swapping out cables, I instead used connectivity like : PC (/w 2.1 HDMI-> Soundbar ( / w 2.0 HDMI ) -> TV. This way I have lost option to use 4k and i don't even have audio format option then.
- Checked driver updates, TV firmware update and Soundbar firmware update - all of them are up to date.
- Tried messing around with local audio drivers and with TV & soundbar settings.

There are many topics regarding this but there isn't definite answer / fix. I am wondering is there anyway to troubleshoot this?

Second problem;

After installing DTS Sound unbound app, I quickly realized I cannot turn on DTS: X ON.
I have checked surround options, saptial sound options but there isn't any option to turn it on. 

On my headphones, I could enable it easily just by going into control panel > sound > and then set saptial sound to DTS: X but here I don't have any option regarding this matter.

Since I am newbie when it comes to audio and stuff like this I am asking for any help what so ever  If there is any info you need, please feel free to comment and I will answer as soon as possible.

PS: I couldn't set images to fit the page correctly, sorry about that in advance

0 Likes
0 REPLIES 0