Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

HW-Q90R soundbar does not pass through Dolby Vision HDR signal

(Topic created on: 22-03-2022 01:07 PM)
494 Views
abc123xyz
Explorer
Options

Update:  I can get Dolby Vision passthrough now! You simply have to turn of the HDR10+ functionality on your Panasonic OLED: TV Settings>Setup>HDMI HDR setting>HDR dynamic setting>HDR10+ Functionality = off

 

I tried to connect my Apple TV 4K (ATV) to my HW-Q90R soundbar to pass through a Dolby Vision HDR (DV) signal to my Panasonic GZ1000 TV. I have also tried this with my Xbox One X (XB1). I was using the Netflix and ATV+ apps. Both devices fail to pass the DV signal through my setup and all I get is HDR10. However, I have read that others have had success passing a DV signal through. I have checked all my settings on all the devices in the chain and they are correct. I am using ultra high speed 8K 48Gbps HDMI cables.  I have also tried connecting the sources directly to the TV and then DV does work.  The problem is then I get really bad lip-sync issues when passing the sound through the TV to soundbar, which eliminates this setup as a solution. I am posting here to hopefully get some feedback from other people who have either successfully passed an ATV or XB1 DV signal through their HW-Q90R and also those that have failed to do so. I am interested to see what TVs, video sources and apps you are using, especially  when using ATV or XB1. I find it very frustrating  and annoying that two common sources can't be used with their optimal video signal considering that the HW-Q90R is Samsung's flag ship soundbar.

0 Likes
23 REPLIES 23
Facakente
First Poster
Options
I know it does not support , what I meant was any setting in this case hdr10 that needs to be disabled to pass the DV through .

But as I said if in the c9 works , it should also work in cx
0 Likes
Largo1
Journeyman
Options

wrong post

0 Likes
Jay46
First Poster
Options

This only got me part of the way for my Apple TV 4K and Q90R soundbar and Panasonic OLED 55GZ1000 TV,

So I needed to do this:

TV Settings>Setup>HDMI HDR setting>HDR dynamic setting>HDR10+ Functionality = off

Also

TV Settings>Setup>HDMI Auto setting> mine was set as "Mode 2" by default". I had to change to "Mode 1" for Dolby vision passthrough to work.

Once I switched to "Mode 1" the Apple TV 4K came up with a box asking me if I wanted to use Dolby Vision, I clicked yes and it worked, however if you don't get a pop up box then I think you can achieve the same thing by going into the Apple TV 4K settings, and activating Dolby Vision under the video settings.

I tested it out with the Lasso TV series on Apple TV and I now have Dolby Vision passthrough working as well as Dolby Atmos working with no audio delay lip sync issues, Finally!

Oh and I also had to update the Q90R firmware, I believe I am now on version 1012

0 Likes
Jay46
First Poster
Options
With help from those on the original poster I got Dolby Vision passthrough working with Q90R sound bar:
So my gear is Apple TV 4K and Q90R soundbar and Panasonic OLED 55GZ1000 TV, So for me I needed to do this: On my Panasonic OLEDTV = TV Settings>Setup>HDMI HDR setting>HDR dynamic setting>HDR10+ Functionality = off Also On my Panasonic OLEDTV TV Settings>Setup>HDMI Auto setting> mine was set as "Mode 2" by default". I had to change to "Mode 1" for Dolby vision passthrough to work. Once I switched to "Mode 1" the Apple TV 4K came up with a box asking me if I wanted to use Dolby Vision, I clicked yes and it worked, however if you don't get a pop up box then I think you can achieve the same thing by going into the Apple TV 4K settings, and activating Dolby Vision under the video settings. I tested it out with the Lasso TV series on Apple TV and I now have Dolby Vision passthrough working as well as Dolby Atmos working with no audio delay lip sync issues, Finally! Oh and I also had to update the Q90R soundbar firmware, I am now on version 1012.6
 
This probably only helps those with a Panasonic OLED TV.
0 Likes