Support

Open search

HW-Q90R Disconnects!

Highlighted
SOLVED
Apprentice

Took delivery of this brand new product on Saturday only to find I'm one of many reporting that it has a fundamental problem. 

 

It disconnects from the Sub and both Rear speakers when it's turned off. Power cycling the Sub and the Rears will reconnect them but this is unacceptable in a product costing £1500.

 

Samsung, please respond and let us know that you're aware of this (unbelievable if you're not) and what action is necessary to make this product function correctly. Either a firmware update or an acknowledgement that we might have a faulty batch and require replacements. 

 

See this link for how widespread this has already become: 

 

https://www.avforums.com/threads/samsung-hw-q90r-soundbar-review-comments.2231672/

 

Please  respond. 

 

 

419 REPLIES 419
Highlighted

All the issues I have heard to do with firmware seems most are related to using USB to do the firmware update.

 

DONT DO IT USE SMART THJNGS!!!!!!!!

Highlighted

hi i have the latest software update but lose my connection to the subwoofer and rear speakers every time i switch off ..patience is running out fast.help please

Highlighted

If you updated throw usb method that's your problem. All the issues I have read, or most are due to updating through usb.

Highlighted

Try Dizzy Glispie

Highlighted
New Member

Hello,

 

I'm also having same issues with sub and rears dropping out occasionally. I have latest firmware updates. ID-set helps but after a while it starts disconnecting again

Highlighted

Well if you used the USB method Therw is your problem. I just leave it on auto update on smartthings and updates automatically in the background.

Hi, is yours working fine then? If you switch off and turn back on, your rear and sub are already connected via wifi? 

Highlighted
Navigator

No issues with mine, although my first one was faulty out of the box. Every issue seems people are using USB to do the update, not smart things which is easier abd safer and auto updates seamlessly, firmware and speakers, USB way won't update speaker firmware snart things updates everything 

 

Its a no brainer to use smart things.

 

When I did get mine replaced the manager of the shop bought the replacement over and the subwoofer would not sync, plugged my orginal subwoofer and synced, and yes so mine works well, no issues, even atmos works through tv app.

Highlighted

Exactly the same problem. I have the latest firmware updated via smart things. When it works it is great but this situation, going on for so long, is pathetic.

Highlighted
First Poster

I've just bought the HW-Q90R soundbar. 

Either mine was already at factory with the latest software version or it updated automatically via the SmartThings App.

 

Sadly my Subwoofer is loosing the connection like every single day!! It stays at red light. While the rear speakers seems to turn on as expected. (Blue light)

 

When it happens, it doesn't even help to power cycle the Subwoofer. (After a power cycle, the light blinks SLOW BLUE, but still doesn't connect. )


The only thing that works is the annoying fact that I need to both rear speakers and the subwoofer into the pairing mode. (Fast blinking blue light) and then on the soundbar initiate the SET-ID function. Afterwards all works fine, I can listen to movies or music for hours just fine. Next day same story.. subwoofer stays RED yet again 😞

 

Software:

M-0128.0
B-1010.5
H-0051.0
FD-0040.0
W-0240.0
S-0136.0
RR-0136.0
RL-0136.0

Top Liked Authors