Support

Open search

HW-Q90R Disconnects!

SOLVED
Apprentice

Took delivery of this brand new product on Saturday only to find I'm one of many reporting that it has a fundamental problem. 

 

It disconnects from the Sub and both Rear speakers when it's turned off. Power cycling the Sub and the Rears will reconnect them but this is unacceptable in a product costing £1500.

 

Samsung, please respond and let us know that you're aware of this (unbelievable if you're not) and what action is necessary to make this product function correctly. Either a firmware update or an acknowledgement that we might have a faulty batch and require replacements. 

 

See this link for how widespread this has already become: 

 

https://www.avforums.com/threads/samsung-hw-q90r-soundbar-review-comments.2231672/

 

Please  respond. 

 

 

424 REPLIES 424

I do have the same   trouble in France

At the first try it was fantastic. I wanted to show to my wife how wonderful it was and then ...

I found your discussion here and I got very disappointed.

I will follow to know when Samsung will update firmware.

Il have the same trouble in France. Soundbar disconnect with all components (sub and rear) when she standby more than fews minutes or hours.

Samsung what about the update !!!!!!!

More than.

Is there a fix from Samsung? I sent my unit back today .
First Poster
Do we know if Samsung has a fix for this issue. I took my unit back today. This is a big problem for them not to know about it. The soundbar is very expensive . This should not be happening .can anyone advise if there is a fix? Tried a few fix by factory resetting g the unit still don’t work . Someone please respond.
That is exactly what I am experiencing so it’s not the speaker it the Sound bar because I can’t see all these right surround speakers being bad please advise if Samsung has a fix. I returned mine today. Sound great when it works but it’s too expensive for this to be happening . Someone please advise!!

I tried this though it work but the next not I trying to watch a movie the right surround was lit with blue light by no audio from sub. Powered off the unit but spears would not go into standby . Had to power cycle the speakers . Go discussed and took it back to Fedex today to send it back to Samsung .

I replied here with a detailed description of a conversation I had with a Samsung representative. My post is nowhere to be seen.

 

Samsung..?

Are u saying the post was deleted? What were your Simpson with the unit.

Hey! I noticed my reply to this post last week was gone too!
Top Liked Authors