Support

Open search

HW-K650 and Two R1 Wirelss Speakers in 5.1 With KS7000 TV

Highlighted
Explorer

When using the K650 sound bar and two R1 Wireless speakers in surround sound mode over wifi with the latest firmware, The quailty of the sound K650 drops, sounds very muddy. As soon as you use the sound bar on it own, the sound bar improves. this is happening for a quite a few users.

 

can you help.

1,601 REPLIES 1,601
Highlighted

Glimm, I dont use spotify or anything like that but I have noticed that after ungrouping or cancelling surround setup the soundbar led reads wi-fi briefly then m.ch.

Highlighted

A small update for my case.

 

As a reminder I'm on the one year older model HW-J650 but had the same issues as everyone else here with the HW-K650. Also the firmware version for both models were the same. Until the problems got fixed (for the K-model). However the firmware version for my J-model did not change.

 

Then, I contacted Kirsty from UK customer support and was bumped to the German customer support as I live in Germany. Today I had a call from a Samsung second-level support agent. I had sent him a short summary and a link to this thread. He explained to me that my model won't accept the K-model firmware. He then noted everything in his system and said that this is enough material to contact the hardware/software guys (in Korea). I will be updated once things move forward. I'm slightly optimistic that it should not take too long to issue a firmware update. The main work should be already finished with the initial update for the K-model. But I'm also a bit suspicious due to the complete and long history of this thread...

Highlighted

Hi Angelo

 

At least you haven't hit a dead end just yet. 

 

I agree even though the firmware is different now I am sure the changes required would be similar if not identical to our soundbar, and hence common sense would tell you it should be an easy fix......... But how many time have I heard that on here lol

 

Let me know if you need any help putting the pressure on. 

Highlighted

I am using HDMI arc to the soundbar. The tv is set to bitstream Dolby digital. Using the app I have setup a surround group.

I now have good surround sound, but voices lack bass. It is basically when people speak and sound comes from the centre the sub does not add anything. Does anyone else have this issue? I do get good bass for general sound effects etc.

Does anyone know how to factory reset the soundbar/sub just in case this helps. 

 

 

Highlighted

Press and hold + and - at the same time on. soundbar for 5 seconds.

Highlighted

@frustrated wrote:

I am using HDMI arc to the soundbar. The tv is set to bitstream Dolby digital. Using the app I have setup a surround group.

I now have good surround sound, but voices lack bass. It is basically when people speak and sound comes from the centre the sub does not add anything. Does anyone else have this issue? I do get good bass for general sound effects etc.

Does anyone know how to factory reset the soundbar/sub just in case this helps. 

 

 


I have on the TV HDMI Audio output = bistream (whatver that is or does) and Audio Output = PCM ( it changes to Dolby Digital automatically if my internal source is a Netflix DD 5.1).  

I connect this soundbar and the two M3's via Wifi multichannel. 

 

The DD sound that comes out is as yours -  low and the voice is tinny.  Surely this can't be normal? 

When I connect a propper AV (with 5.1 speakers),  I do not get this, I get fantastic sound.  Suspect this is due to the k650 soundbar having issues playing DD5.1.

 

Have done a reset of K650 soundbar but it remains bad (low volume and the voice is tinny) sound.   

 

Nobody can tell me what these TV audio output settings do and why the sounbar does not have these settings.  

 

Samsung is quiet on this, but some obscurantists offered their own pseduo explanations to no avail. 

Highlighted

Hi guys

 

This is the issue I've been telling you about! Center channel doesn't get  subwoofer reinforcement. From my experience it's not really related directly to Dolby (though it's obvious in dolby tracks as the center channel is a voice channel) but soundbars internal active crossover and bass management. It happens no matter the source, center channel just doesn't get bass support from the subwoofer. 

 

Moreover, it looks like not every K650 is affected by this, so it's most likely a hardware issue. 

 

Highlighted

Hi Peejay84, 

 

Sounds like it's not fixed for some. I haven't noticed any of the issues you have but I will re test and confirm over the weekend. 

 

I have had some connection issues but all in all soundbar sounds good for me. 

Highlighted

Can you please confirm how you are using your soundbar. I am using HDMI arc with the surround set up using the app. The tv is set to audio format Dolby digital and HDMI audio format bitstream. The surround works well, but voices from the sound Bar are tinny. 

 

I thought using HDMI arc in this way would allow the sound Bar to do all of the decoding rather than the tv. Very similar to if a non samsung surround setup wasps being used. 

Highlighted
I am using just wifi/multichannel only with no optical or hdmi and only TV as source.

I have a samsung hub but currently not using this