Close

What are you looking for?

cancel
Showing results for 
Search instead for 
Did you mean: 

Original topic:

HW-K650 and Two R1 Wirelss Speakers in 5.1 With KS7000 TV

(Topic created on: 22/06/17 15:51)
podavies
Explorer
Options
Audio & Video

When using the K650 sound bar and two R1 Wireless speakers in surround sound mode over wifi with the latest firmware, The quailty of the sound K650 drops, sounds very muddy. As soon as you use the sound bar on it own, the sound bar improves. this is happening for a quite a few users.

 

can you help.

1,601 REPLIES 1,601
Ant993
Apprentice
Options
Audio & Video

Hi Guys,

 

i have been been keeping tabs on this discussion, great work from all and very helpful. I took my two r7's back after seeing how long this has been going on but may take the plunge again now it's fixed.

 

I'm by no means an expert when it comes to audio but as a network engineer I do know routers to some extent, just wanted to share a bit of advice for everyone although I'm sure most of you are aware. When it comes to setups like this it's always best to hardcode your ip addresses on the router, you can do this by reserving the iP addresses on the router based on the devices MAC address. Every device that connects to a network will have its own unique MAC address. If you don't reserve them then they will pick up an up address dynamically and renew that address every 30 days.  My friend has an expensive media centre setup and every 30 days his system would go down, this was the reason. 

 

I have a virgin router, I can see all the devices connected to it when I login to it and I can reserve the addresses easily enough so only that device can use that address. 

 

Hope this helps.

Robbienobs
Pathfinder
Options
Audio & Video

I had this about a week ago. Had some weird ip conflict and had to reset the router to factory but all has been fine since. 

 

I reset all speakers first and then reconneofresh

 

I am on BT smart hub 

0 Likes
Reply
simon_w
Explorer
Options
Audio & Video

And is your TV connected via the wifi to the same channel or Ethernet ?

 

I have had simmilar problems to this in the past and the solution for me (after discussing it at length with Samsung) was to install a Samsung WAM250 Hub - this creates its own dedicated static network for the soundbar and speakers and works a treat.  

£30 from Richer Sounds - money well spent!

GliMM
Apprentice
Options
Audio & Video

Hi. I have mentioned this earlier, but according to Samsung, only channel 36 to 48 is supported when using 5Ghz with an external router, there is no such limit when using 2.4Ghz.

 

I had this issue earlier and everything started working on 5Ghz when I switched to a channel within the supported range.

On the other hand i have 2 times experienced wierd drop outs of my R1 spekers, they just wen away from my radar, I could not see them in my Multiroom app, the tv detected them but could not use them and no way of restarting could get them up and running again, 

the only solution for me was to make a factory reset on them (holding down + and - at the same time ~5 sec).

Re add them as new speakers and all was fine.

0 Likes
Reply
GliMM
Apprentice
Options
Audio & Video

I must raise a question here. After the upgrade of firmware, thus getting great sound and all that, I experience issues with the grouping of my speakers when including my Spotify app (on my phone)

If i create a surround setting for my TV, the TV will connect when turned on.
If I turn OFF the tv, the speakers will revert to three different devices (K650 + R1 +R1)
I can use them (individually) as external speakers from my Spotify app, and even group them using the grouping feature in my multiroom app.
Spotify the detects this new group and I can send my sound using all three speakers at the same time.
BUT if I turn on my tv it will break the group and use them as Surround group, if I then turn of my TV they will show up as tree individual speakers again..

I can swear that before the update i could use Spotify and detect the surround config as one single unit.

I would love to be able to use my system for both tv surround and when the tv is turned off, still use the group as Spotify speakers, without the need to recreate the grouping or surround setup every time.
Any ideas?

0 Likes
Reply
scott
Apprentice
Options
Audio & Video

Have you tried switching to tv speaker before turning off tv? 

I have a similar problem where my bluray player has problems creating a surround setup unless I select tv speaker on tvs audio settings.

0 Likes
Reply
Kilo
First Poster
Options
Audio & Video

Well, I have chaned the channel to 40 and I can now connect it. But.

 

Now the sound really sucks. The volume problem is back, well more ö less, the ***** system regroup it self and the sound is behind. I'm gonna take a break and spend a couple of hours with the kids now and just hope some magic just fixes this *****. 

0 Likes
Reply
simon_w
Explorer
Options
Audio & Video

Hi Kilo - one step forward...

 

Dont know if it is related but after the firmware update my volume levels still needed to be reset in the TVs Wireless Speaker Management before they worked properly - just moving one of the sliders and saving kicked the whole thing into action and it has worked fine since...

0 Likes
Reply
GliMM
Apprentice
Options
Audio & Video

@scott wrote:

Have you tried switching to tv speaker before turning off tv? 

I have a similar problem where my bluray player has problems creating a surround setup unless I select tv speaker on tvs audio settings.


 

Yes, doing this will ungroup the speakers. 😞
Selecting my soundbar as sound output will regroup them again.

So I see the following behavior.

1. Tv OFF, Samsung Multiroom App ON.
Speakers are ungrouped:
K650
R1 Left
R1 Right
Spotify show them as three separate speakers

I add them in a surround configuration using the Multiroom app.

2. I turn the TV ON, the TV uses them as surround (app displays Soundbar K650(5CH) R1 Left & R1 Right in Surround mode.
Spotify display the K650 Soundbar but NOT the R1 left and R1 Right as available devices

3. I turn the TV OFF, In the Samsung Multiroom app the speakers are Ungrouped
Spotify show all three speakers as available devices.

4. I turn the TV ON again, the TV uses them as surround (app displays Soundbar K650(5CH) R1 Left & R1 Right in Surround mode.
Spotify display the K650 Soundbar but NOT the R1 left and R1 Right as available devices

5. Keeping the TV ON, i select TV speakers as sound output
In the Samsung multiroom app the speakers are ungrouped and Spotify show all three speakers as available devices.

6. I turn the TV OFF, now i use Samsung multiroom app and create a GROUP, using all three speakers (Not surround setting).
I name the group and save.
In Spotify I see the GROUP as available device, if i connect and play sound comes from all three speakers

7. I turn the TV ON, In the multiroom app, the Group changes to Surround and we are back to Step 2.
Spotify only displays Soundbar K650 as available device (not the R1 speakers).

8. I turn the tv OFF, In the multiroom app, the speakers are UNGROUPED, reverting to 3 separate devices in Spotify once again. the group created in step 6 is lost never to appear again.


I am pretty sure that the above did NOT happen before the update.
could anyone confirm my steps, do you see the same behavior??

 

 

0 Likes
Reply
GliMM
Apprentice
Options
Audio & Video

Sound behind?
Are you sure you are using wifi? Sound out of sync was common using Optical cable?
Just want to verify.
There is a sync setting in the sound options where you can compensatefor this. (down to 0).

 

 

Glad midsommar! :smiling-face:

 

0 Likes
Reply
scott
Apprentice
Options
Audio & Video

Glimm, I dont use spotify or anything like that but I have noticed that after ungrouping or cancelling surround setup the soundbar led reads wi-fi briefly then m.ch.

0 Likes
Reply
Angelo2002
First Poster
Options
Audio & Video

A small update for my case.

 

As a reminder I'm on the one year older model HW-J650 but had the same issues as everyone else here with the HW-K650. Also the firmware version for both models were the same. Until the problems got fixed (for the K-model). However the firmware version for my J-model did not change.

 

Then, I contacted Kirsty from UK customer support and was bumped to the German customer support as I live in Germany. Today I had a call from a Samsung second-level support agent. I had sent him a short summary and a link to this thread. He explained to me that my model won't accept the K-model firmware. He then noted everything in his system and said that this is enough material to contact the hardware/software guys (in Korea). I will be updated once things move forward. I'm slightly optimistic that it should not take too long to issue a firmware update. The main work should be already finished with the initial update for the K-model. But I'm also a bit suspicious due to the complete and long history of this thread...

0 Likes
Reply
Robbienobs
Pathfinder
Options
Audio & Video

Hi Angelo

 

At least you haven't hit a dead end just yet. 

 

I agree even though the firmware is different now I am sure the changes required would be similar if not identical to our soundbar, and hence common sense would tell you it should be an easy fix......... But how many time have I heard that on here lol

 

Let me know if you need any help putting the pressure on. 

0 Likes
Reply
frustrated
Apprentice
Options
Audio & Video

I am using HDMI arc to the soundbar. The tv is set to bitstream Dolby digital. Using the app I have setup a surround group.

I now have good surround sound, but voices lack bass. It is basically when people speak and sound comes from the centre the sub does not add anything. Does anyone else have this issue? I do get good bass for general sound effects etc.

Does anyone know how to factory reset the soundbar/sub just in case this helps. 

 

 

0 Likes
Reply
scott
Apprentice
Options
Audio & Video

Press and hold + and - at the same time on. soundbar for 5 seconds.

0 Likes
Reply
NotSamsung
First Poster
Options
Audio & Video

@frustrated wrote:

I am using HDMI arc to the soundbar. The tv is set to bitstream Dolby digital. Using the app I have setup a surround group.

I now have good surround sound, but voices lack bass. It is basically when people speak and sound comes from the centre the sub does not add anything. Does anyone else have this issue? I do get good bass for general sound effects etc.

Does anyone know how to factory reset the soundbar/sub just in case this helps. 

 

 


I have on the TV HDMI Audio output = bistream (whatver that is or does) and Audio Output = PCM ( it changes to Dolby Digital automatically if my internal source is a Netflix DD 5.1).  

I connect this soundbar and the two M3's via Wifi multichannel. 

 

The DD sound that comes out is as yours -  low and the voice is tinny.  Surely this can't be normal? 

When I connect a propper AV (with 5.1 speakers),  I do not get this, I get fantastic sound.  Suspect this is due to the k650 soundbar having issues playing DD5.1.

 

Have done a reset of K650 soundbar but it remains bad (low volume and the voice is tinny) sound.   

 

Nobody can tell me what these TV audio output settings do and why the sounbar does not have these settings.  

 

Samsung is quiet on this, but some obscurantists offered their own pseduo explanations to no avail. 

0 Likes
Reply
Peejay84
Navigator
Options
Audio & Video

Hi guys

 

This is the issue I've been telling you about! Center channel doesn't get  subwoofer reinforcement. From my experience it's not really related directly to Dolby (though it's obvious in dolby tracks as the center channel is a voice channel) but soundbars internal active crossover and bass management. It happens no matter the source, center channel just doesn't get bass support from the subwoofer. 

 

Moreover, it looks like not every K650 is affected by this, so it's most likely a hardware issue. 

 

0 Likes
Reply
Robbienobs
Pathfinder
Options
Audio & Video

Hi Peejay84, 

 

Sounds like it's not fixed for some. I haven't noticed any of the issues you have but I will re test and confirm over the weekend. 

 

I have had some connection issues but all in all soundbar sounds good for me. 

0 Likes
Reply
frustrated
Apprentice
Options
Audio & Video

Can you please confirm how you are using your soundbar. I am using HDMI arc with the surround set up using the app. The tv is set to audio format Dolby digital and HDMI audio format bitstream. The surround works well, but voices from the sound Bar are tinny. 

 

I thought using HDMI arc in this way would allow the sound Bar to do all of the decoding rather than the tv. Very similar to if a non samsung surround setup wasps being used. 

0 Likes
Reply
Robbienobs
Pathfinder
Options
Audio & Video
I am using just wifi/multichannel only with no optical or hdmi and only TV as source.

I have a samsung hub but currently not using this

0 Likes
Reply
frustrated
Apprentice
Options
Audio & Video

I should also add i am using the tv tuner, tv netflix and tv google play movies rather than external sources.

0 Likes
Reply