Support

Open search

HT-J4500 home cinema, cycling on and off repeatedly.

Highlighted
SOLVED
Navigator

Although I've had it a good few years, never having a problem with it, my home cinema system is throwing a fit. It seemed to start when the blu ray/ dvd drawer wouldn't fully extend. I gently pulled it and inserted the disc and it seemed to work okay. The next day, when I switched it on, it now cycles through "LOAD", "No DISC" repeatedly, even when trying to use "D in", "AUX" or any other setting. I've disconected the drive from the rest of the unit, no difference. I've reset the unit whilst it was in stand by mode, nothing. It's not dirty inside, all very clean looking. Anyone know what's going on... Please help.

I've looked over the net all to no avail. 

1,056 REPLIES 1,056
Highlighted

MartyinToronto: that is different then what they asked from me. Samsung Canada asked me everything the same as you except for the receipt. They just asked for the place and date of purchase and I sent them all that info, without the receipt and they sent me the prepaid label and assured me both shipping and repair would be repaired. 

I live in PEI and it was sent to Markham service centre - over 1600kms away. Sent it July 2nd and they received it July 6th and I have not heard anything back yet. I sent an email to the repair centre last night and hope to hear an update. Maybe I will do a chat line with Samsung as well for an update. Good luck with your player with Samsung Canada. 

Highlighted

The Netherlands here.

BD-J5700/ZA

 

My player has been doing this since the 16th of June. After may calls (frustrating ones) and messaging them and only getting B.S. yesterday after being sent another part of the Netherlands for customer service station, which was not a place to take our unit. we made a call to Samsung and after getting one very rude guy we hung up, tried one more time and got a woman who knew about the issue and took all the info, then she sent a postage label. It was picked up today 

 

Now a waiting game to see what happens.

Highlighted
Apprentice

@scotchbaz wrote:

Although I've had it a good few years, never having a problem with it, my home cinema system is throwing a fit. It seemed to start when the blu ray/ dvd drawer wouldn't fully extend. I gently pulled it and inserted the disc and it seemed to work okay. The next day, when I switched it on, it now cycles through "LOAD", "No DISC" repeatedly, even when trying to use "D in", "AUX" or any other setting. I've disconected the drive from the rest of the unit, no difference. I've reset the unit whilst it was in stand by mode, nothing. It's not dirty inside, all very clean looking. Anyone know what's going on... Please help.I've looked over the net all to no avail. 


Thanks to the OP . Contacted online chat on 27 June, collected by DPD and sent for repair. Had it returned today and all working again, software/firmware replaced. Fair play to Samsung for sorting this issue 👍👏👏

Highlighted
Explorer

Just had my HT J4200 back from RepairTech. Has had the Software/Firmware reset. Seems to be working OK, but I will not be connecting it to the internet, just in case Samsung send a faulty update again (Once bitten, twice shy). Thanks @scotchbaz for starting this topic. 

Highlighted

Got my ht-j4500 back on Monday and the 'issue' has been fixed so a success of sorts. 

 

I was hoping that, whilst they were there, they'd fix something else: it just stopped playing blu-ray  discs earlier this year. If you put a blu-ray in it can't read the disc. Especially as the paperwork they send you implies they give it a once-over! Alas, no. It still won't pay blu-ray. But you can't have everything. 

 

Overall, whilst I'm glad Samsung did the fix for free I don't rate their customer service. The whole experience has felt like an awkward apology rather than an 'our bad, let's put this right and show that we care'. When i initially tried to arrange the repair they were very defensive and seemed to be worried I was trying to have them over!! (By requesting a fix for a fault that they still haven't publicly acknowledged!)

 

I love my Samsung and am glad it's back and I get that things go wrong and it can't always be helped but it's how you deal with it that matters and  on customer service alone, I'll only buy Samsung in the future if i can't get a similar product from another company. The trust is gone. 

 

I'm sure they'll miss the few thousand pounds i might have spent on them otherwise ! 😆

 

Anyway, the new sony surround sound I bought before i realised what was going on is awesome and now my lads have a Samsung surround system in their bedroom. It all worked out alright. 

 

 

Highlighted

From Belgium, HT-J4530.

 

Received confirmation today from Servilux that the homecinema has been repaired.  One week after request, this is not bad. Waiting now for the recovery.

Highlighted

Hi all

 

Received my HT5500 back from repair today (UK poster) and glad to say the unit is now working fully working again as new.  

 

Initial report to Samsung was on 25th June so a couple of weeks to get all sorted from start to finish.

 

Am grateful to Samsung for doing the repair though still no definitive info on what the cause was and what's actually been repaired.

 

Hope everyone else ends up getting the same positive result!

Highlighted
What was said as the cause of the malfunction to those who repair the device in the service ? is the source of the fault updated? or certificate problem ? motherboard failure in turkey is saying demand higher wages
Highlighted
First Poster

For those in South Africa having this issue. I took my HT-J5500 into the local Samsung Service Centre, had the device booked in and was given a service order no. I followed up earlier this week and the repair person mentioned that Samsung were in the process of fixing the issue. I followed up again today and they indicated that they are now busy with the repairs of all the units and they had recieved a good amount of devices for repair. They would contact me once completed. Looks like Samsung will cover the repair at no cost so thats at least a positive. 

Highlighted

@RobZA and other South African users that may be wondering. My device was taken in for repairs on 3 July 2020 - after quite a bit of runaround I might mention. On Sunday I received a call from Samsung stating that they did not have a repair yet.  When asking why, seeing that others have already had their's repaired, I was told no parts available and some other noncense reasons for not repairing it yet. Yesterday I sent an email to Samsung to request a formal update as to how this is going to be resolved for us in South Africa. Low and behold, this morning I received a text message to so they acknowledge my complaint and provided me with a reference number. This afternoon I was informed I could collect me repaired device. This I have done and can confirm all is working again. @samsung Thank you for the repair, however please work on your execution. This has been a month long ordeal for me to get resolved due to know fault on my part. 

Top Liked Authors