Support

Open search

HT-J4500 home cinema, cycling on and off repeatedly.

Highlighted
SOLVED
Navigator

Although I've had it a good few years, never having a problem with it, my home cinema system is throwing a fit. It seemed to start when the blu ray/ dvd drawer wouldn't fully extend. I gently pulled it and inserted the disc and it seemed to work okay. The next day, when I switched it on, it now cycles through "LOAD", "No DISC" repeatedly, even when trying to use "D in", "AUX" or any other setting. I've disconected the drive from the rest of the unit, no difference. I've reset the unit whilst it was in stand by mode, nothing. It's not dirty inside, all very clean looking. Anyone know what's going on... Please help.

I've looked over the net all to no avail. 

1,059 REPLIES 1,059
Highlighted

If you don't mind me asking how long did it take to be repaired? My J5500 is due to be collected today by DPD

Highlighted

@Farah92 Mine is being collected today too by DPD. Did they tell you that the driver will provide an address label as many on here are saying one was sent to them via email. 

 

Highlighted

They did say DPD would provide an address label, its going to repairtech an theres only one branch of that company in the uk so wouldn't be hard to track down. 

Highlighted
Thanks Farah92 thats a big relief. Just a waiting game now. I'll post again when I receive mine back with the results. Good luck
Highlighted

HT-J4200 , just called Samsung Support Slovakia, they know about the problem, but do not know the solution yet, recommended to wait few weeks and call again 😞

Highlighted

Hi everyone. 

Here's the full story then. 

Monday 22nd June, my BD J5500 woke up in a restart loop, couldn't do anything about it for a couple of days.

Wednesday 24th June, 3:30pm, contacted Samsung Live Online Chat, Arvin was incredibly helpful, took the serial number and details, wasn't bothered that I didn't know the date of purchase (it is quite old now) and left it that someone would call me the following day.....

Thursday 25th June, 1:45pm took a call from Samsung Support, they organised DPD to come and collect it and even said they would bring packaging as I didn't have the original box!

Friday 26th June, 12:00 DPD came with the promised packaging (which I could almost have fitted my TV into🤣) and took my bluray away

Tuesday 30th June, 9:30am, received an email from RepairTech informing me my unit was going in for initial diagnostic.

9:40am, 2nd email from RepairTech with the repair report stating software/firmware replaced.

2:45pm, 3rd email from RepairTech saying it was in quality control.

Wednesday 1st July, 6:30am, Samsung emailed to say DPD would deliver back on July 2nd.

Thursday 2nd, 12:30, DPD delivered back my bluray played all clean and fixed.

Great service and job thank you Samsung.

Hope the rest of the world catches up. 

Stay strong peolle, they have the tools to fix your devices. 

Good luck. 

Highlighted

Same - negative - experience with Samsung CZ/SK... I have some doubts that Samsung in other countries will handle that the same way as in UK/USA... Shame on you Samsung!

Highlighted

Good to hear that there are success stories. I am still in the process with mine in South Africa. So far my story is not such a good one. Will post my experience once I hear back from service centre, as I took it in today. 

Hi MadPad, have you plugged the device back to the internet? Just asking because someone in previous posts mentioned that their device came back with WiFi disabled.
Highlighted

Hi Trevor, Where in South Africa are you based? I am in Pretoria and was advised to take it to PMC Electronics