What are you looking for?

Showing results for 
Search instead for 
Did you mean: 

Anynet/HDMI-CEC and ARC not working

(Topic created on: 26-04-2018 11:19 AM)
Hi there,

I have this problem for over a month now.

I have a Samsung TV model UE49MU8005 connected to a Pioneer Receiver model VSX-LX302. Everyhting is well connected, as far as i know, TV firmware is 1210.8.

Tv is connected through a recent HDMI cable (UHD, ARC, etc etc) from the ARC output of the receiver to the ARC input of the TV (HDMI 4). Anynet is on.

When I disconnect the cable and connect it again, it starts identifying the source on the TV and it always says "unknown source" so i have to manually configure the tv remote. After it detects my Receiver, turns it on and off ok, and finishes the connection. Everything seems ok. But the problem starts here:

- The sound does not come out through HDMI from the TV if I select an app from the hub. Neither it does if it's connected to the antenna of the tv.

- I have sound from the cable box and from a PC both connected to the receiver.

- The receiver has CEC on but it the sound is not there. When I disconnect the CEC on the receiver and connect it again, it starts searching for CEC devices but the answer is "no CEC device"! Although the TV is connected of course..

- Anynet stops working too, it doesn't control my receiver when this is happening.

- This bug goes on and off. It works sometimes, other times it doesn't. It seems that theres is some problem in the TV that disconnects automatically HDMI CEC, and then it just doesn't come back.

- I changed cables, update firmwares, disconnected everything and waited, then connected again, called Samsung support and they just don't seem to know what I'm talking about... The problem always persist.

Frankly, I'm considering returning the TV. It's new and for the price it should NEVER cause such hassle.

This is about something that should work perfectly and is not doing so. And it seems that everyone at Samsung knows the problem exists, they just don't know how to solve it... (according to the countless discussions about this topic, at least at the US community..).

Please help!


327 REPLIES 327

I've installed a WiFi controlled outket behind tv which I can turn off and on easily.  Arc works perfect for me as long as reciver is turned off after the tv and then on before tv.  It never stops working while watching something.  If my kids turn them off in the wrong order I simply turn plug off then on with app.

Black Belt 

@BUFree wrote:

I've installed a WiFi controlled outket behind tv which I can turn off and on easily.  Arc works perfect for me as long as reciver is turned off after the tv and then on before tv.  It never stops working while watching something.  If my kids turn them off in the wrong order I simply turn plug off then on with app.

Thing is it should work without all that messing about.  I have had 3 Samsung TV's without it doing that. Sounds like a fault. 


Agree it is a Samsung issue, but this work around works for me.  More of a pain to return.


It should work. TV can control your receiver's power.

In fact, that's the first step for when you setup TV universal remote.

Maybe you just never set the universal remote and it just works partially as a result?

You might need to tweak some options on TV and/or receiver.


Yes it should of course work but for many people and for several years apparently simply has not.  After finding this thread, I found this huge 105 page one on he issues with ARC on the US support site.  Locked by Samsung and marked as "solved" though as you will see reading through it, the issue appears not only not solved but still happening on new sets (like mine) and now I cannot even post to that thread...


That is just insane.  I bought a 65" 4K curved Samsung over the summer and updated my A/V receiver from my old Onkyo 705 to a TX-NR777.  ARC didn't work out of the box so I figured my cables were just older than the 1.4 required to support CEC/ARC so I bought new 2.0b cables.  Still didn't work.  Spent 1.5 hours on the live-chat with Samsung support with them remoted into my TV.  The TV and the receiver were both set correctly  (CEC/Anynet+ enabled, right jacks, etc...).  He did some sort of soft reboot and the TV finally showed an option for Audio Out (HDMI) which had never shown up in my 3 days of adventuring - ARC still didn't work.  I finally tapped out, told him I'd work with Onkyo since the TV was showing the HDMI option as being set.  Then I found this thread.  I unplugged my TV and my receiver for 1 minute, plugged them both back in, turned on the receiver first, then the TV and boom - just like that... ARC works.


Not sure how this is on a Samsung forum and has been known for years and wasn't the first thing either of the two tech support fellas got me to try.  Really not sure how Samsung hasn't addressed this issue in their firmware (the TV was already up-to-date, ran two updates on the receiver out-of-the-box).  It is insanity.  


I will put a wi-fi outlet on my TV and receiver to reset it hands-free in the future... but unbelievable how they can't create devices that work with what should be an industry standard that has been around since 2009.  Ridiculous.


Well, it seems that the apparent 'solution' that worked for me has been working for others too.

Recently mine has been working with no issues, except if I connect some other gear to my receiver (gear that does not use the samsung remote - like my turntable or DTS Play-Fi connection) which for some reason makes it loose again the connection to ARC. Then, I just unplug everything for at least 1 minute and when I reconnect it detects ARC again..

I totally agree that this is absolutely ridiculous and shows a lot how these companies are more interested in getting our money than delivering good quality products and solving the issues without forcing the consumer to deliver goods with all the hassle that it carries.

They should at least reimburse all the expenses that people needlessly make in trying to make it work (like buying new cables, etc.).

That is why I don't mark this problem as solved. Because it is not solved!!

This is just a work-around that I found out worked.

So please don't mark it solved until Samsung comes with a solution!


First Poster

Bought my Samsung QE65Q7FN last week and im having the same problems with it not holding the ARC HDMI - CEC connection. Angry is an understatment.


Went back to Richer Sounds armed with this and the US forums and they were equally shocked and i'm swapping to an LG OLED 65 B8 


Wont be buying Samsung again sadly 



Hi Noddles.... That was a good move. I have my system working quite well but using two work arounds. Essentially, I do not use the Samsung TV for anything but a monitor. I have a Roku, Samsung BR/BVD, and and XBox connected to my Onkyo AVR and then connect the AVR to the Samsung thorugh HDMI-1.


I purchased a Caavo system that is a powerhouse Universal Remote and everthing works perfect. No relying on the ARC and also not relying on the CEC to make everthing work together. I have spent about $200 and over 40 total hours to get the system in this shape.


Exactly the same problem with my Samsung UE65NU8070 TV connected to my Onkyo TX-NR709 reciever.  ARC & CEC worked just fine with my previous Samsung TV (PS51E6500RU) in the exact same set up, cables and all!


Samsung support has been completely useless, with responses ranging from failing to even understand the issue to promises of calls back that never happen.


Clearly Samsung can make this work 100% reliably as proved by my old TV so why they can't figure it out now is a mystery to me and obviously an even bigger mystery to Samsung!


For now, I have had to turn ARC off and resort to putting in an optical link between TV and receiver. CEC is still mostly functional but not recognising individual sources connected to the receiver as it used to.