Support

Open search

1010.5 Firmware Update for hw-Q70R/hw-Q80R/hw-Q90R Soundbars

Highlighted
SOLVED
Explorer

Good morning friends.

 

I've performed the firmware update for my HW-Q90R soundbar.

 

Given that there is no official statement from Samsung with the details of the update  I would like to check with the community what new features have been included.

 

- How can I check now the firmware version on the bar, to check if the rears are updated as well? In the past just by holding the sound mode button on the remote with the soundbar off the different versions appeared on the display.

Now it is not case. Now by holding sound mode for 5 seconds with the bar off it enables a new functionality: Test Tone

 

 

NEW FEATURES

 

- EARC functionality is enabled, this is great.

- Test tone: What it this for? It performs a test of the sound of the different channels, is it useful for anything else?

- Now in the sources appeared TV SPEAKERS, what is this for?

 

I would like to check specially if the update has included any update of the rears and subwoffer

509 REPLIES 509
Highlighted
Why not?
If I connect the Shield TV directly to the TV, the image does not break through and the sound also.
Before the update there were no such problems, only the sound in Netflix stuttered.
Highlighted

Perhaps you ha


@vladlenas wrote:
Why not?
If I connect the Shield TV directly to the TV, the image does not break through and the sound also.
Before the update there were no such problems, only the sound in Netflix stuttered.

Perhaps you have a defective unit. I have never had such problems with mine, either before or after the update, although I don't have the Shield. Try to contact Samsung customer support.

Highlighted

It's not because you don't have any problem than the update works well for all. It depends on many factor, thus the TV. Mine works great through blutooth and optical, but not in ARC anymore. The soundbar gets in PRT mode (protected mode I suppose) then shutoff when plugged in ARC since this update, and I don't think it's a defective unit. Everything else works as is supposed (bass, soundbar, rears).

Highlighted

@Olivier75009 wrote:

It's not because you don't have any problem than the update works well for all. It depends on many factor, thus the TV. Mine works great through blutooth and optical, but not in ARC anymore. The soundbar gets in PRT mode (protected mode I suppose) then shutoff when plugged in ARC since this update, and I don't think it's a defective unit. Everything else works as is supposed (bass, soundbar, rears).


Especially because you say it goes to "PRT mode" I would contact Samsung customer support.

Of course, if it works well for me it doesn't mean it must for everybody, but if it were a spread phenomenon caused by the firmware update itself, we would have already seen another update, given the apparent severity of the issue. So, once again, if I were you I would contact Samsung customer support.

 

This topic tends to mix actual problems with other issues caused by bad cables/connections/confusion about the meaning and the relationships between eARC/Dolby Atmos/whatever.

Regarding actual problems, at least two of the posters already said they have fixed by getting a replacement unit from Samsung.

Highlighted
I have no issues with none at all with my Nivia shield and get atmos also
Highlighted

Hi

 

i have the same issue of simplink now not working and no switching.   Did you ever get this resolved?

Highlighted
Did you get an answer? Same issue for me
Highlighted
Don’t worry I fixed it - had to re set up the universal remote function on the TV (LG) if that helps. Now ATV and Tv / soundboard remotes all sync up
Highlighted

I'm back,

 

My initial problem - that prompted a service center repair, with two pcba's replaced - was no connection to sub & sats upon power up.  That issue appears to have been solved with three weeks worth of usage since it's return.  The new problem that now popped up is no volume from sub & sats even though they power on fine.  Essentially rear sound goes quiet with DVD's between chapter queues and/or pauses.  Pretty strange.  I'm beginning to wonder if the service center just swapped in 'used' boards they had laying around.  In any event, I did notice that my "W" firmware module never updated past 240.0 with the latest firmware release of 1010.5.  So, in reviewing this entire thread I noticed that one poster said the secondary 'Update' process needed several attempts... so I performed that tonight.  What a total pain in the &^%$.  But it worked.

 

Now my module list looks like this:

M - 0128.0

B - 1010.5

H - 0051.0

FD - 0040.0

W - 0242.0 <<<<<<<<<

S - 0136.0

RR - 0136.0

RL - 0136.0

 

Not sure how the "W" got to 242.0 - anyone else seeing that? - but I'll take it.  For anyone confused, the "W" is the wireless firmware module.

 

I'll report back on my audio drops in a few weeks.  If they aren't solved, Samsung is taking this stuff back for another repair cycle.  BTW, they extend the warranty period by 90 days for repairs... in case anyone wanted to know.

Highlighted

Someone hooked up the Q90r to the LG CX via eARC and can answer me some questions ?