Open search

Watch doesn't count laps while swimming after last update


After last software update my Watch lost ability to count laps while swimming. Previously it worked quite well, even detecting style. Now regardless of the style of swimming the distance is always zero. 

I tried rebooting and resetting. Must be a software bug introduced in last update. I saw some posts on reddit complaining about the same.

Is someone in Samsung working on a fix ?

AndrewL Moderator
@majapu: On the Galaxy Watch, go to S Health > Rotate the bezel clockwise to access the exercise tracker screen > Workout > Swimming > Target (set a target , or select Basic Workout) > Workout Screen > Pool Length (set the length). This should hopefully resolve your issue, however if the problem persists then you may wish to visit an authorised Support Centre to arrange for the watch to be inspected. To find your nearest one please check the following link, select 'Mobile Device' and enter your post code.

I tried all kinds of swimming pool lengths and training modes, but it doesn't help, because the Watch cannot count a single stroke I am making, no matter a swimming style.

It is clearly a software bug introduced with the last OneUi update, so I don't expect going to a service will help much. 

Are your programmers at least investigate that bug ? I saw same issues reported on Internet. 


I just realized, that floor couter doesn't work and also barometer/altitude meter widget. All of those have worked before OneUI update.

New Member
I am having same problem and followed your directions but since doing a recent update don't have any of those options anymore.
When I go to S Health there is no workout selection. When I click on swimming, as I have been doing all along there is no longer the option to change any features as it just goes straight to recording your workout.
Any one had this happen a d have found how to get around it?

Same issue here. My Sport was uncannily accurate at tracking laps, split times, and strokes up until about a week ago. As of about 1-2 weeks ago (coincidentally about the time I noticed that my watch had clearly experienced a software "update" because the appearance of many of my screens was clearly different than before. . . ) my Sport doesn't count a single lap in swimming mode. Nothing. The timer starts, but it just runs continuously until I stop swimming and manually press the Back button to stop it. As previous posters have noted, my total distance and lap counts are both 0. The workout is uploaded to the Samsung Health app on my phone, but it only says that I swam for XX minutes. There is no lap data at all. 

I downloaded the Swim dot com app to my watch and phone and using Swim my watch DOES give me a lap count with split times, etc. So, it's NOT my watch. It's the Samsung software IN my watch. Software which was working perfectly well before it was "updated" a week or two ago. 

VERY ANGRY about this. Samsung needs to figure this out and revert the software to whatever it was previously - when it worked! 

First Poster

I agree....I only get one lap recorded but I've swam at least 60.....I've tried everything...come on Samsung...please sort this out for us.

Top Liked Authors