Open search

Samsung Galaxy Watch 46mm (BT)- Update fails

First Poster

For the last 3 months I tried to update the watch  and it always failed. Sometimes it failed while copying the update to the watch, but mostly this happened. After successfully copying I hit "install now", I get a message that the watch will disconnect now but nothing happens. 


This happened with the update from November and with the update that rolled out yesterday in the Netherlands.

Im currently on SW Version R800XXU1BRJ4 


First I tried a reset and then had to realize my watch backup dissappeared. So the watch data was lost and I also lost a few weeks of apparently unsynched samsung health data. I repeated the reset multiple times because it didn't matter anymore. Nothing helped, so I had hopes for this update but the same problem occured again.

This is just the update and backup issue. I came across quite alot problems with this watch and I'm at a point where deeply regret buying it. 


Any solution for this update problem?

AndrewL Moderator
@Jingx: Where did you download the update from? Do you have the watch connected to a mobile phone via the Galaxy Wearables App? If so you can open the app on your phone, go to Settings > About Watch > Update Watch Software and proceed from there.
First Poster

I tried updating the watch using the galaxy wearables app on my phone. There is no option in the suggested menu run the update using the watch directly. The only thing I can do is seeing the version numbers of the software etc and turning the developer mode on. 

Top Liked Authors