Support

Open search

S8 smart view not working

SOLVED
First Poster

Hi, 

Smart view won't connect properly between my s8 and Samsung tv. It immediately disconnects.

I can screen mirror my old s6 no problem so assume something wrong with my s8 software and not the tv. 

Any advice to fix please?

Jon 

 

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

I was having the same issue. I did the developer thing and authorized wireless display it didn't work. WHAT WORKED was simply downloading the app samsung smart view screen mirroring. I use to just pull the top tab down and scroll over 1 page to the smart view symbol that's pre installed into my note 8 but it stopped working. But since I downloaded the app it's been working fine.. Hope this helps.

42 REPLIES 42
Superuser I
Superuser I
Hi Jon,

I've been reading up on this for you buddy and this method seems to have worked for a few people.

On your phone go to Settings and then scroll down to About Phone and in there click on Software Information then click on Build Number about 7 times (don't worry a little countdown will tell you how more times to click it) and that'll give you Developer Options and they should be switched on automatically. In Developer Options scroll down to Networking and toggle Authorise Wireless Display Devices on and then try and make a new connection to Screen Share and it should connect and when it does you can toggle Authorise Wireless Display Devices off again and switch off the Developer Options and that's it your screen sharing should be up and running again buddy.
First Poster

Hi John,

 

Thank you for your time and email.

 

I followed the steps exactly as you said but unfortunately I still get the same message on my phone....

'couldn't turn on smart view'

 

the tv first says connection made but the tv screen goes blank and then back to the normal tv picture.

 

Anything else I can try please?

 

Kind regards

Jonathan

 

 

Superuser I
Superuser I

Hi Jonathan,

 

Sorry for the late reply buddy. 

 

First of all make sure your screen resolution is set to FHD and not WQHD. 

 

Also try and add your device to Samsung Connect and see if that helps.

New Member

I was having the same issue. I did the developer thing and authorized wireless display it didn't work. WHAT WORKED was simply downloading the app samsung smart view screen mirroring. I use to just pull the top tab down and scroll over 1 page to the smart view symbol that's pre installed into my note 8 but it stopped working. But since I downloaded the app it's been working fine.. Hope this helps.

New Member

After trying everything mentioned with no success, I tried the obvious. I went into my tv settings clicked on check for software updates, 1 update found ,Boom smart view works.😁

I have same issue . Samsung have no intentions to fix it anytime soon as I've been repeatedly informing them for months and they just pretend we're all doing it wrong.

Smartview since the update is broken.
That does work but it prevents you from running files outside of mp4. I now after years of building my hobbies around these features have to spend hours ever day transferring and converting my video formats. It's not a solution if the features needs a work around to do what it has done since day one.
New Member

@Jon54321 wrote:

Hi, 

Smart view won't connect properly between my s8 and Samsung tv. It worked up until recently

 


 

Apprentice

I have a Nokia but wanted to share that by removing all devices in TV settings (general-external device manager-device connection manager-device list) I was then prompted to allow phone at next connection attempt and it is working again for me now

Top Liked Authors