Support

Open search

Ramdom vibrate notifications - galaxy watch

Apprentice
Try
Go to watch
Settings
Connections
Bluetooth
Turn bezel to alerts and turn off
Apprentice

I would love to turn it off too. Did anybody find a way? Or are we stuck with a dud watch?

Apprentice

Did you try what I posted?

Apprentice
?? Try
Apprentice

Ahh that will be it. Well done Simon!!!

New Member

The random vibrations seem to be "Bluetooth Disconnection Alerts". Go into Settings - Connections - Alerts. Turn this feature off.  Solved the issue for me!

First Poster

I've tried that and it doesn't work. It's getting worse too. Happens every few minutes. I'm about to throw it in the trash! 

First Poster

I do believe that was the solution for this malady.  Thank you so much!

May the TortZ be with you......AlwayZ
Top Liked Authors